Switching from address tag to "paragraph" text, text still appears as address text.

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: TucsonTester1, Assigned: mozeditor)

Tracking

Trunk
mozilla0.9.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE, URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.1)
BuildID:    20010726

When selecting the address tag and typing a few lines of text then switching 
back to body text. Text still appears as address text. 

Reproducible: Always
Steps to Reproduce:
1.open new document
2.select address from the tool bar
3.type a line of text, hit enter
4.type another line of text, hit enter 
4.change text back to body text
5.continue typing

Actual Results:  The text still appeared as address text. 

Expected Results:  Normal text would display instead of address text. 

If you highlight the text then change it back it works fine. But it leaves an 
address tag after the last line ... in the sorce code.

Comment 1

18 years ago
confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
*** Bug 96237 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Akkana--can you check this out and reassign to core if it's a backend bug?
Assignee: brade → akkana

Comment 4

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 5

17 years ago
This is working for me with a build from a couple days ago, following the
instructions.  TusconTester, could you try it again and see if it's been fixed?
(Reporter)

Comment 6

17 years ago
Tested on the 9-10 build .. works now .. changing status to fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Verified in 9-17 Build
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
Tested with the 20011017 build in WIN XP
Changing status to reopen

I found that the original issue is no longer present.  However, a similar issue 
is coming up.  When selecting the address format and typing a few lines of text 
then switching to paragraph, the text still appears as address text.

Reproducible: Always
1. Launch Composer
2. Select "Address" from the format drop down menu on the tool bar
3. Type some text
4. Hit enter 3 times
5. Select "Paragraph" from the format drop down menu on the tool bar
6. Type some text

Actual Results:  The text still appeared as address text. 

Expected Results:  Normal text would display instead of address text. 

Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 9

17 years ago
It looks like this is a problem with paragraph mode.  Not only does paragraph
mode not cancel the current mode (address, heading, etc.) when it's selected
(which is what you describe, and I see it too), but it's not clear what it does
do.  Selecting paragraph mode does insert one <p> tag wherever I am when I flip
over to paragraph, but subsequently hitting return doesn't insert any more <p> tags.

If switching to paragraph mode means (as it currently does) "Insert one <p> tag
at the current location but otherwise proceed as usual", it shouldn't be in that
dropdown, since that isn't how the other items in the dropdown behave.  An
"insert paragraph break" toolbar button (not that we have space for one) or menu
item would be much more intuitive.

Cc'ing Kathy, Charley, and Joe in the hope that one of them knows how this is
supposed to work.

Comment 10

17 years ago
I thought Joe had a bug about "undoing paragraph doesn't really do that". Maybe
this was that bug?
Setting to "Paragraph" is not supposed to be setting a "mode", just applying 
a paragraph style once. But I don't quite get why you think it is different from
other "paragraph styles" in the dropdown list. The heading styles are a special
case where we end that style with the next return/enter keypress, but the others
seem to work like <p>: return/enter inserts a <br>.
We all know how hideous the <br> issue is and hope that Web Composer can start 
using <p>s instead of <br>s soon and let just the "mail rules" use <br>.
Joe: Is that still planned for 1.0 timeframe?
Bug also 92686 relates to the issue of "Return inserts line break, not paragraph 
break".

Comment 11

17 years ago
The dropdown feels like a mode to me: it shows a list of modes, only one of
which is selected.  If I select Address, then when I start typing, the next
stuff typed will be an address.  If I then select Paragraph, Address is no
longer selected, so I would expect that <address> would no longer apply to the
next stuff I typed.  But it does -- in fact, it's not at all obvious how to get
out of address mode once you're in it, but the dropdown doesn't show that you're
still in it.  That can't be right.

Paragraph is confusing for a different reason: it shows that you're inside a <p>
tag, but what if you want to create another <p> tag?  I guess there isn't any
way?  To the user it's not at all obvious what the difference is between
Paragraph and Body Text.

Charley, I hope you don't mind if I hand this to you.  There's clearly a UI
issue involved here, and I clearly don't know how it's supposed to work, whereas
it sounds like you at least know something about it (and maybe you can explain
to us why it makes sense, if it's working as intended).
Assignee: akkana → cmanske
Status: REOPENED → NEW

Comment 12

17 years ago
Sounds like an editor core problem -- i'll debug it.

Comment 13

17 years ago
This all seems to be working correctly now! I think Joe fixed something related.
Changing from "Address" or "Paragraph" style back to "Body Text" terminates those
styles correctly now, as evidenced by viewing the HTML Source.
Sujay: please retest.
(Reporter)

Comment 14

17 years ago
Tested useing the 20011101 build in WIN ME

What Akknana still seems to be applicable in some ways.  When moving from 
Address to Paragraph it still retains the style of the address.  However, 
moving from address into the body style seems to be working appropriately 
initially.  This is something that is destined to confuse the user.  They will 
be seeing address style text when the drop down menu says paragraph.  i.e.

1. Launch Composer
2. Select "Address" from the format drop down menu on the tool bar
3. Type some text
4. Hit enter
5. Select "Paragraph" from the format drop down menu on the tool bar
6. Type some text

Appears as this in HTML:

<body>
<address>Testing Address<br>
<p>Change to paragraph<br>
<br>
</p>
</address>
</body>
</html>

The phrase "Change to paragraph" still shows as the address format.  Whereas if 
you were to change to the body format and not to paragraph, the HTML would look 
like this:

</head>
<body>
<address>address test <br>
</address>
test body<br>
<br>
</body>
</html>

Another note along the same lines:  When you do switch to body and not 
paragraph, your text appears accurately, but when you place your caret back up 
inside the "address" text, the menu still is displaying it as body text.  There 
seems to still be some sort of issue going on in terms of the format menu and 
what it displays as well as the address format not reacting appropriately when 
changed.  I would expect to see the menu bar reflect the style of the text my 
caret is placed in.

Comment 15

17 years ago
Yep, changing from "address" to "paragraph" embeds the "<p>" instead of
terminating the <address> and changing to <p>. Doesn't seem right to me.
Assignee: cmanske → jfrancis
Component: Editor: Composer → Editor: Core
Summary: Switching from address tag to body text, text still appears as address text. → Switching from address tag to "paragraph" text, text still appears as address text.
Whiteboard: EDITORBASE
(Assignee)

Comment 16

17 years ago
I bet the DTD is telling me that I can put a <p> inside an <address>.  I will
investigate.  Fortunately not many folks use address.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Updated

17 years ago
Whiteboard: EDITORBASE → EDITORBASE-

Comment 17

17 years ago
Not obeying an attibute/mode change. Keeping EDITORBASE.
Whiteboard: EDITORBASE- → EDITORBASE
(Reporter)

Comment 18

17 years ago
do not see the problem in 2001-12-18-03 in Win2k.  appears to be fixed.

Comment 19

17 years ago
Tucson/Michael, should we mark this WFM if its not a problem for you anymore?

Comment 20

17 years ago
Looks good to me on build 2001121803.

I am resolving this WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 21

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.