Disjoint labels don't work correctly

VERIFIED DUPLICATE of bug 94268

Status

()

Core
Layout
--
major
VERIFIED DUPLICATE of bug 94268
17 years ago
16 years ago

People

(Reporter: Ross Bagley, Assigned: clayton)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

Depending on variables beyond my understanding, stuff within <label></label>
tags that is separate from the <input> tag is incorrectly placed or even missing
from the page.  This is not compliant with the HTML spec and is currently
preventing me from porting my web application to work under Mozilla.

I came up with a simple html example that shows the label text badly misaligned
in the cell that should completely bound it:

located.http://www.geocities.com/windsorhome/labeltest.html

There is a plain text 'x' on either side of the label.  The 'x' before shows
that the width and the rendering start point are both wrong.

If you take my example and mess around with the text in the label and the other
cells (change the width size for real jollies), you'll see that this is
completely broken.

Another example that I can't reproduce in simple html, the label looks to be
about the right width, but the text is simply missing.  It could be being
rendered completely outside of the screen or under the nearby text input, I
can't tell.  The example given displays enough of the problem so that if you can
figure it out, I'm sure my other error will be fixed as well.

Reproducible: Always
Steps to Reproduce:
1. Browse to page


Actual Results:  See page and description

Expected Results:  See page and description

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 94268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied

Comment 3

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.