CSS `order` affects nav-index/tabindex

RESOLVED DUPLICATE of bug 812687

Status

()

defect
RESOLVED DUPLICATE of bug 812687
5 years ago
5 years ago

People

(Reporter: stepien.nicolas, Unassigned)

Tracking

26 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
Posted file css-order.html
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.77 Safari/537.36

Steps to reproduce:

http://www.w3.org/TR/css3-flexbox/#order-accessibility

>Likewise, ‘order’ does not affect the default traversal order of sequential navigation modes (such as cycling through links, see e.g. ‘nav-index’ [CSS3UI] or tabindex [HTML40]).


Logically order elements in the HTML, change the visual order via CSS flex order.
Try tabbing through the elements.


Actual results:

Tabbing goes through visual order. `order` effectively affects the default traversal order.


Expected results:

Tabbing goes through content order. `order` does not affect the default traversal order.
Reporter

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812687
You need to log in before you can comment on or make changes to this bug.