Closed Bug 962646 Opened 7 years ago Closed 4 years ago

Fx Android opens SUMO with javascript disabled from the Sync settings screen

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ioana.chiorean, Unassigned)

References

Details

(Whiteboard: [closeme sync-1.1-deprecated][fix in comment 12])

Attachments

(1 file)

Attached image screenshot
Build: 2014-01-22 Nightly Firefox 29
OS: Android 4.2.2
Device: Galaxy Nexus 

Precondition: consider yourself a kid born in 2001 in January (1st-21st)

Steps:
1. Open Fennec and go to Settings ->  Sync
2. Tap 'Show me more'
3. Scroll down the page

Expected result:
- I should be able to see images for the demo how to add a device to FX Sync

Actual result:
- Images are not displayed and the hyperlinks are visible. The (non-it) user will be confused .
Reproducible with

Build: Firefox 26.0
OS: Android 2.3.6
Device: Htc Desire HD


Build: Firefox 27.0 Beta
OS: Android 4.1.2
Device: Samsung Galaxy SII
Same issue in Android 4.4.1 - Samsung Galaxy S2 i9100
I could swear we already have a similar bug about mobile pages displaying weirdly when launched from mobile for things that are marked as relevant for mobile and desktop products. But I can't find that bug right now :/
Priority: -- → P3
Whiteboard: u=user c=wiki p= s=2014.3
Target Milestone: --- → 2014Q1
We've decided to remove our <noscript/> fallback for images. Firefox removed the checkbox for disabling js and the KB is very broken without js anyway.

Grabbing in the current sprint to slamdunk it.
Assignee: nobody → rrosario
Whiteboard: u=user c=wiki p= s=2014.3 → u=user c=wiki p=1 s=2014.2
So, the browser disables JS when you follow the "show me more" link? Weird. That seems like a bug in Firefox, no?
Moving this over to Android. It is opening SUMO with javascript disabled. The SUMO knowledgebase requires javascript to work properly.
Assignee: rrosario → nobody
Component: Mobile → FxA
Priority: P3 → --
Product: support.mozilla.org → Firefox for Android
Whiteboard: u=user c=wiki p=1 s=2014.2
Target Milestone: 2014Q1 → ---
Summary: Show me more from Sync settings in Fx Android doesn't display images → Fx Android opens SUMO with javascript disabled from the Sync settings screen
Duplicate of this bug: 963139
It uses an Android WebView. Javascript is disabled by default.
Component: FxA → Android Sync
Product: Firefox for Android → Android Background Services
Interesting.  I did not realize WebView was crippled by default.  For hysterical raisins, we used a WebView for Sync.  We're going to be loading links in Fennec for FxAccounts, will try to address this at the same time.
Blocks: 964863
Depends on: 964883
Depends on: 965020
This worked on mfinkle's phone, and the fixes are all painful for other reasons, so holding off on landing this for now.

Pull request:

https://github.com/mozilla-services/android-sync/pull/402
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Hardware: ARM → All
Assignee: rnewman → nobody
Status: ASSIGNED → NEW
Whiteboard: [closeme sync-1.1-deprecated][fix in comment 12]
No longer blocks: 964863
(In reply to Richard Newman [:rnewman] from comment #12)
> This worked on mfinkle's phone, and the fixes are all painful for other
> reasons, so holding off on landing this for now.


Do you mean Mark didn't see the issue on his phone?
(In reply to Kadir Topal [:atopal] from comment #13)

> Do you mean Mark didn't see the issue on his phone?

There are two issues reported in this bug.

One is FxA "show me more" links. All links inside FxA activities now open in the browser.

The other (the title) is about SUMO display from the old Sync setup screen. SUMO displayed and behaved correctly on mfinkle's phone from that location.

Given that (a) we can't reproduce the report, and (b) we don't care about Old Sync, I'm inclined to not change this.
Duplicate of this bug: 863062
No longer depends on: 964883
This was part of legacy Sync.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.