Closed Bug 962736 Opened 6 years ago Closed 6 years ago

Update Shumway to version 0.8.6

Categories

(Firefox Graveyard :: Shumway, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 29

People

(Reporter: yury, Assigned: yury)

References

Details

Attachments

(1 file, 1 obsolete file)

Log:

#1062 Monomorphize some more function calls
#945 Adds a "Report Problems" entry to the extension's context menu
#975 Fixes #1066
#1068 Refactor streaming source to use MediaSource
#1070 Cleanup
#1071 Refactors initialization from the FirefoxCom
#1072 Introduces FrameScheduler
#1073 Improves frame scheduler; adds mp3 playback off-sync tracking
#1076 Ignore mouse events on HUD display
Depends on: 958110
Attached patch Update Shumway to version 0.8.2 (obsolete) — Splinter Review
Attachment #8363888 - Flags: review?(till)
Comment on attachment 8363888 [details] [diff] [review]
Update Shumway to version 0.8.2

Review of attachment 8363888 [details] [diff] [review]:
-----------------------------------------------------------------

patch looks good. r=me on the structure and all, with the understanding that the actual code changes aren't reviewed.
Attachment #8363888 - Flags: review?(till) → review+
Keywords: checkin-needed
patching file browser/metro/base/tests/mochitest/browser_selection_basic.js
bad hunk #1 @@ -313,15 +313,47 @@ gTests.push({
 (15 15 48 47)
Keywords: checkin-needed
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #3)
> patching file browser/metro/base/tests/mochitest/browser_selection_basic.js
> bad hunk #1 @@ -313,15 +313,47 @@ gTests.push({
>  (15 15 48 47)

Wrong bug, sorry.
https://hg.mozilla.org/integration/fx-team/rev/24fda7c805e3
Assignee: nobody → ydelendik
Whiteboard: [fixed-in-fx-team]
Backed out in https://hg.mozilla.org/integration/fx-team/rev/7a7ba4d11e5e because either this or bug 962736 (or much less likely one of the other patches Ryan pushed with them) permanently broke xperf tests on Win7:
https://tbpl.mozilla.org/php/getParsedLog.php?id=33488315&tree=Fx-Team
Whiteboard: [fixed-in-fx-team]
The backout went green, so it was one of these two patches that broke it.
Am I correct in assuming that the text in comment 6 was copy-pasted from the other suspected bug, and that this bug is, indeed, the much less likely candidate? The error doesn't look like something this patch could conceivably have caused.
(In reply to Till Schneidereit [:till] from comment #8)
> Am I correct in assuming that the text in comment 6 was copy-pasted from the
> other suspected bug, and that this bug is, indeed, the much less likely
> candidate? The error doesn't look like something this patch could
> conceivably have caused.

Ugh, yeah, sorry, it was copy/pasted from bug 960051. The two much-less likely patches I was talking about were Android-only or a three-line change to a CSS file, neither of which seemed like it would make Windows tests access those three files.

Since my backout turned it green, either Shumway's update in this bug or pdf.js's update in 960051 caused it.
In that case, my money is on bug 960051: it has password prompting-related changes, so changed patterns of key storage accesses seem to make sense.

The update here, OTOH, is really unlikely to be related.
Sounds plausible to me.
https://hg.mozilla.org/integration/fx-team/rev/41143dba70eb
Whiteboard: [fixed-in-fx-team]
This did cause the xperf regression. Backed out.
https://hg.mozilla.org/integration/fx-team/rev/861d0354e018
Whiteboard: [fixed-in-fx-team]
Additional changes:

#1088 Factor out all text layout from TextField into TextFieldContent
#1089 Lazy initialization of AddonManager; async getVersionInfo()


Try push
https://hg.mozilla.org/try/rev/fd900d9b5ceb
Attachment #8363888 - Attachment is obsolete: true
Attachment #8365078 - Flags: review?(till)
Summary: Update Shumway to version 0.8.2 → Update Shumway to version 0.8.6
Comment on attachment 8365078 [details] [diff] [review]
Update Shumway to version 0.8.6

Review of attachment 8365078 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the try run returning green. And sorry for the mess.
Attachment #8365078 - Flags: review?(till) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4f4f4b20efc7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Blocks: 980742
Depends on: 989333
No longer depends on: 989333
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.