Closed Bug 962758 Opened 6 years ago Closed 6 years ago

Changes to JS build files cause configure to error out

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla29

People

(Reporter: RyanVM, Assigned: glandium)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Push: https://hg.mozilla.org/integration/mozilla-inbound/rev/a8c663915e02

https://tbpl.mozilla.org/php/getParsedLog.php?id=33379395&tree=Mozilla-Inbound

make[5]: Entering directory `/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/js/src'
STOP!  configure has changed and needs to be run in this build directory.
Please rerun configure.
To ignore this message, touch "config.status" in the build directory,
but your build might not succeed.
make[5]: *** [config.status] Error 1
make[5]: Leaving directory `/builds/slave/m-in-l64-d-0000000000000000000/build/obj-firefox/js/src'
make[4]: *** [js/src/export] Error 2
So, it turns out this is not exactly new... it's caused by a combination of bug 903369 and changes to js/src/configure.in that end up not changing anything in config.status.
Blocks: 903369
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Attachment #8364121 - Attachment is obsolete: true
Attachment #8364121 - Flags: review?(gps)
Attachment #8364325 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/15899a6820f4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.