weird tab highlights in Australis

RESOLVED DUPLICATE of bug 885139

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 885139
4 years ago
4 years ago

People

(Reporter: vlad, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8363949 [details]
weird gray shadows

This is very weird; I have these odd shadows behind my pinned tabs.  I haven't restarted my browser to see if something is wedged or if it's permanent.

Updated

4 years ago
Blocks: 939862
Do you have a lightweight theme enabled? If so, that's likely bug 885139.
Flags: needinfo?(vladimir)
Looks like a LWT to me so duping to bug 885139. Leaving needinfo to confirm.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885139
Hm, I'm pretty sure I was still seeing this on a 3-21 nightly (which is after the 3-20 date for the fix for bug 885139).  Toggling LWT off and then back on does fix it.  I'm not sure how to follow the STR in bug 885139 though (it seems like it's just plugging in a new monitor and then maximizing the window?).
Flags: needinfo?(vladimir)
Bug 885139 has to do with the cropping of the header image to the width of the display in pixels and then having the Firefox window on a display with a higher resolution making the image too small for that resolution. Since we are cropping to the display size, not the window size, it's easiest to see if the window fills the whole screen. There is a resize handler to on the window to swap in an uncropped or newly cropped image if we're on a different screen resolution but the LightweightThemeListener code added with Australis wasn't getting notified to make its adjustment.

When you see this, could you check in the Browser Console to see if there are any mentions of "theme" or CSS errors related to background-image? Please re-open if you do reproduce this on a build from 3-21 or later.

Thanks
You need to log in before you can comment on or make changes to this bug.