Window Close Button Event Dependency on Aero, MenuBar, FullScreen States

RESOLVED DUPLICATE of bug 746583

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 746583
5 years ago
4 years ago

People

(Reporter: stormseye, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: affects Win 7, Win XP, Linux)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I created a firefox extension similar to the "Minimize on Start and Close" add-on (https://addons.mozilla.org/en-US/firefox/addon/minimize-on-start-and-close/?src=api).  Basically, it closes all tabs and minimizes the window when the window's Close button [X] is clicked.  It captures the Close event with "window.addEventListener('close', someFunction, false);"

This works fine in some cases but not in others.   Here is what I found using themes in the Windows 7 desktop Personalization Control Panel:

1. With the menubar disabled, does it work in all of the listed Aero themes?
OK
2. With the menubar enabled, does it work in all of the listed Aero themes?
OK

3. With the menubar disabled, does it work in the Windows 7 Basic theme?
BUG
4. With the menubar enabled, does it work in the Windows 7 Basic theme?
OK

5. With the menubar disabled, does it work in the Windows 7 Classic Theme?
BUG
6. With the menubar enabled, does it work in the Windows 7 Classic Theme?
OK


Here is what I found running Firefox on Windows XP running in VirtualBox:
7. With the menubar disabled, does it work in Windows XP?
BUG
8. With the menubar enabled, does it work in Windows XP?
OK


Here is what I found running Firefox on Linux Mint running in VirtualBox:
7. With the menubar disabled, does it work in Linux?
OK
8. With the menubar enabled, does it work in Linux?
OK

Fullscreen is a PROBLEM in Windows 7 with or without the menubar and with or without an Aero theme.

Fullscreen is a PROBLEM in Windows XP with or without the menubar.

Fullscreen is also a PROBLEM in Linux Mint with or without the menubar.


Actual results:

The BUG or PROBLEM indicated in the "steps to reproduce" is that the window was closed instead of being minimized.  The Close event is not captured by the js extension.

In the cases indicated as OK, the window minimizes as expected.


Expected results:

The window should minimize when the window's Close button [X] is clicked.

The "window.addEventListener('close', someFunction, false);" should capture the Close event without being dependent upon the status of Aero, MenuBar, of FullScreen.
(Reporter)

Updated

5 years ago
Whiteboard: affects Win 7, Win XP, Linux

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746583
You need to log in before you can comment on or make changes to this bug.