[B2G] [Everything.me] Apps generated by search results cannot be added to the homescreen

RESOLVED DUPLICATE of bug 960659

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 960659
4 years ago
4 years ago

People

(Reporter: CKreinbring, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-2)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
After performing a search on Everything.me, the apps shown in the search results cannot be added to the homescreen by long-pressing their icons.

Repro Steps:
1) Update Buri to Build ID: 20140122004001
2) Tap the Everything.me search bar.
3) Enter a search term that will return apps.
4) Long-press on one of the results and observe the device's reaction.

Actual:
Nothing happens, no context menu appears.

Expected:
After a couple of seconds, a context menu appears with an option to add the app to the homescreen.

Environmental Variables
Device: Buri 1.3 mozilla RIL
Build ID: 20140122004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71a8786c3815
Gaia: 744fb691c2b2a25a07c5d19fabf5748ae9aba4d9
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=9256
See attached video clip
Selecting an everything.me section and long-pressing an app within does bring up a context menu.
(Reporter)

Comment 1

4 years ago
Does not repro on Buri 1.2 mozilla RIL.
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 2

4 years ago
Created attachment 8364093 [details]
Video clip of long-pressing everything.me apps
I don't know whether this is a requirement or not, but this code lives in the homescreen app for 1.3 and below.
Component: Gaia::Browser → Gaia::Homescreen
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 960659

Updated

4 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.