Crashing enterring Mail recipient after scrolling up and down

VERIFIED DUPLICATE of bug 96291

Status

VERIFIED DUPLICATE of bug 96291
18 years ago
14 years ago

People

(Reporter: yulian, Assigned: sspitzer)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
20010821 Wins and Linux builds

Steps to reproduce:

1. Type in three to five recipients in Mail recipient To: fields 
2. Scroll bar appears on the side of Addressee block in the new Msg window
3. Scroll up and down
4. Add one more recipient at the next empty To: field
5. Enter whatever even though you cann't get focus in the field
6. Hit Return key...CRASH

Stack trace from talk back report as following:

Incident ID 34331697
Stack Signature nsOutlinerBodyFrame::SetVisibleScrollbar() daaa503c
Bug ID
Trigger Time 2001-08-21 11:56:31
Email Address yulian@netscape.com
User Comments
Build ID 2001082108
Product ID MozillaTrunk
Platform ID LinuxIntel
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Stack Trace
nsOutlinerBodyFrame::SetVisibleScrollbar()
nsOutlinerBodyFrame::SetView()
nsOutlinerBodyFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::GetPrefSize()
nsSprocketLayout::GetPrefSize()
nsContainerBox::GetPrefSize()
nsBoxFrame::GetPrefSize()
nsSprocketLayout::GetPrefSize()
nsContainerBox::GetPrefSize()
nsBoxFrame::GetPrefSize()
nsSprocketLayout::GetPrefSize()
nsContainerBox::GetPrefSize()
nsBoxFrame::GetPrefSize()
nsSprocketLayout::PopulateBoxSizes()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsPopupSetFrame::DoLayout()
nsBox::Layout()
nsSprocketLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsStackLayout::Layout()
nsContainerBox::DoLayout()
nsBoxFrame::DoLayout()
nsBox::Layout()
nsBoxFrame::Reflow()
nsRootBoxFrame::Reflow()
nsContainerFrame::ReflowChild()
ViewportFrame::Reflow()
nsHTMLReflowCommand::Dispatch()
PresShell::ProcessReflowCommand()
PresShell::ProcessReflowCommands()
PresShell::FlushPendingNotifications()
PresShell::HandlePostedReflowCallbacks()
PresShell::ProcessReflowCommands()
PresShell::FlushPendingNotifications()
nsCSSFrameConstructor::ContentAppended()
StyleSetImpl::ContentAppended()
PresShell::ContentAppended()
nsXULDocument::ContentAppended()
nsXULElement::AppendChildTo()
nsXULElement::InsertBefore()
nsXULElement::AppendChild()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsXBLPrototypeHandler::ExecuteHandler()
nsXBLKeyHandler::KeyPress()
nsEventListenerManager::HandleEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsGenericElement::HandleDOMEvent()
nsHTMLInputElement::HandleDOMEvent()
PresShell::HandleEventInternal()
PresShell::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsView::HandleEvent()
nsViewManager::DispatchEvent()
HandleEvent()
nsWidget::DispatchEvent()
nsWidget::DispatchWindowEvent()
nsWidget::OnInput()
handle_key_press_event()
dispatch_superwin_event()
handle_gdk_event()
libgdk-1.2.so.0 + 0x17e4f (0x40337e4f)
libglib-1.2.so.0 + 0x117f3 (0x4036a7f3)
libglib-1.2.so.0 + 0x11dd9 (0x4036add9)
libglib-1.2.so.0 + 0x11f8c (0x4036af8c)
libgtk-1.2.so.0 + 0x94803 (0x4027f803)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1c177 (0x404ad177)

Comment 1

18 years ago
Duplicate of bug 96291?
yes, it's a dup.

thanks hwaara.

*** This bug has been marked as a duplicate of 96291 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.