Closed Bug 963008 Opened 6 years ago Closed 6 years ago

msgIdentity has no space between email address and account name

Categories

(Toolkit :: Themes, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla29

People

(Reporter: nONoNonO, Assigned: Paenglab)

Details

Attachments

(3 files)

When composing a message on Windows 7 (Default Aero theme), there is no space between the email address and account name on the From: line, making it less readable. The only distinction between the two is, that the account name is grey and italic. On Windows XP there is a space between the two elements. Also if you click on the account the pop-up list that appears does have a space between the two elements.
Attached image From line Aero.png
Attached image From line XP.png
I don't quite understand why I see this difference, because both Aero and XP seem to have the same styling in menulist.css, both for menulist-label and menulist-description:

.menulist-label {
  margin-top: 0 !important;
  -moz-margin-end: 0 !important;
  margin-bottom: 0 !important;
  -moz-margin-start: 1px !important;
}

.menulist-description {
  font-style: italic;
  color: GrayText;
  -moz-margin-start: 1ex !important;
}
But the .menulist-label rule on line 163 resets the -moz-margin-start to 0px again. We need after this rule again a .menulist-description rule to set the needed margin.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yup, I just noticed the extra rule on @media (-moz-windows-default-theme)...
This is a toolkit issue -> moving to it.
Component: Message Compose Window → Themes
Product: Thunderbird → Toolkit
Attached patch patchSplinter Review
This patch adds the .menulist-description rule after the .menulist-label rule in @media (-moz-windows-default-theme) to give the -moz-margin-start back.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8364496 - Flags: review?(jmathies)
Comment on attachment 8364496 [details] [diff] [review]
patch

I'm not the right reviewer for this, I think Neil might be able to help based on blame.
Attachment #8364496 - Flags: review?(jmathies) → review?(neil)
Attachment #8364496 - Flags: review?(neil) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cc2ef6030968
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla29
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.