Launch apps directly from a web page via an Android Intent

RESOLVED DUPLICATE of bug 851693

Status

()

RESOLVED DUPLICATE of bug 851693
5 years ago
5 years ago

People

(Reporter: guillebert, Unassigned)

Tracking

26 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36

Steps to reproduce:

google changed last year the way an android app should ne launched by clicking a web link. we changed the code of our mobile landpage according to:

https://developers.google.com/chrome/mobile/docs/intents?hl=ja

after it was implemented on tricount, the code seems to works on main browsers except unfortunately firefox (it was repported by users a few days ago).

please try with demo tricount 
http://tricount.com/vgDvuypwshGSSBxw




Actual results:

toast saying no app is installed that can manage the action (translated from french)


Expected results:

if tricount was installed, the demo tricount (related to the link) should be uploaded in the tricount android app.
Would be good to have this bit of platform integration. 

Depending on how your app is designed we have a UI for helper apps as described in bug 899376.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
OS: Windows 8.1 → Android
Hardware: x86_64 → All
Dup of bug 851693?
Lets say it is.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851693
Not tracking the dup.
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.