Closed Bug 963118 Opened 7 years ago Closed 7 years ago

Firefox Accounts (Android Settings) - Configure your Fx Account will open Firefox for android

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
fennec 29+ ---

People

(Reporter: ioana.chiorean, Unassigned)

Details

Build: 2014-01-23 Nightly Firefox 29
OS: Android 2.3.5
Device: HTC Desire HD

Steps:
1. Settings ->  -> Add account -> Firefox Account
2. Configure a new account
3. Tap home button 
4. Go to settings -> Accounts -> Firefox Account -> configure your Fx Account

Expected result:
- The screen for configure your firefox account will be display 

Actual result:
- Firefox for Android will be open (if you are at a certain page - that will be open[1], if you do not have it open will open the about:home page[2])

Note:
[1] https://www.youtube.com/watch?v=srwV97kTs4c
[2] https://www.youtube.com/watch?v=wR0SgUJPguM
- this was always reproducible on this phone (HTC Desire HD/Android 2.3.5)
- I was able to reproduce this some times on Galaxy Nexus (Android 4.2) but only randomly :(
tracking-fennec: --- → ?
tracking-fennec: ? → 29+
This should be fixed, worth retesting.
Keywords: qawanted
Flags: needinfo?(ioana.chiorean)
Keywords: qawanted
I am not able to reproduce it anymore. 

Device: HTC Desire HD
OS: Android 2.3 
Build: Nightyl 30.0a1 (02/05)
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ioana.chiorean)
Resolution: --- → WORKSFORME
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.