Closed Bug 963156 Opened 6 years ago Closed 6 years ago

[B2G][Calendar] Scrolling in day view is not smooth

Categories

(Core :: Panning and Zooming, defect)

28 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 962881
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected

People

(Reporter: bzumwalt, Unassigned)

References

()

Details

Description:
While in the Calendar apps day view tab, scrolling vertically appears to be significantly choppy and less smooth than scrolling in week view tab and compared with other apps.

Repro Steps:
1) Updated Buri to BuildID: 20140123004001
2) Open Calendar app
3) Tap day tab at bottom of screen
4) Drag finger up and down to scroll

Actual:
Scrolling appears choppy and not smooth in Calendar's day view tab.

Expected:
Scrolling is smooth across Calendar app.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140123004001
Gaia: 6fbeac2415f07f10de181f0877ddf67ee299b885
Gecko: e8f6bdf8db3d
Version: 28.0a2
Firmware Version: V1.2-device.cfg


Notes:

Repro frequency: 3/3, 100%
See linked: video clip - http://youtu.be/OWr3O2EGTkA
Issue occurs on 1.4

Result: Scrolling appears choppy and not smooth in Calendar's day view tab.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140123040608
Gaia: 00d8d05f0d0730a3cbf17635ad6a6b197a2ce7c9
Gecko: 1a75d37e1e39
Version: 29.0a1
Firmware Version: V1.2-device.cfg
Does this reproduce on 1.1?
Keywords: qawanted
This issue also occurs in Gallery app as well as all tabs of Music app. This issue does not occur when scrolling in Settings, Browser, or Contacts apps. This issue stops occurring with APZ turned off.
Keywords: qawanted
kats - is this a dupe of bug 942750?
Blocks: gaia-apzc-2
Component: Gaia::Calendar → Panning and Zooming
Flags: needinfo?(bugmail.mozilla)
Product: Firefox OS → Core
Version: unspecified → 28 Branch
This looks like a dupe of bug 962881 which is a recent regression; the fix is on b2g-inbound now.
Flags: needinfo?(bugmail.mozilla)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 962881
You need to log in before you can comment on or make changes to this bug.