[B2G][Browser] Search bar and tabs intermittently disappear on home page after closing a tab

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Browser
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Josh Schmitt [Joshs], Assigned: benfrancis)

Tracking

({regression})

unspecified
1.3 C3/1.4 S3(31jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 affected, b2g-v1.3 fixed)

Details

(Whiteboard: dogfood1.3 [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
Browsing heavy image sites like imgur.com or senorgif.com will create an error which closing the tab on the error message can cause the search bar and tabs to disappear on the home page.

Repro Steps:
1) Updated Buri to BuildID: 20140113004002
2) Proceed to the browser app
3) In the search bar type 'senorgif.com'
4) Once gif is playing, move around the website
5) Select 'Close Tab' on error popup

Actual:
No search bar or tab selection on the browser home page.

Expected:
The browser home page has the search bar and the tabs selection.

Environmental Variables:
Device: Buri 1.3 MOZ 
BuildID: 20140121004137
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Gecko: 6f7dfe36ab6c
Version: 28.0a2
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 6/10, 60%
See attached: Home_Page.mpeg video
(Reporter)

Comment 1

4 years ago
Created attachment 8364469 [details]
log.txt

Issue occurs on 1.2, I have attached a logcat. I have also included a link to the video here: http://www.youtube.com/watch?v=V3F4UXFtjUI

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20140121004053
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/c9f305c1d9a7
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2-device.cfg
Does this reproduce on 1.1?
Keywords: qawanted

Updated

4 years ago
QA Contact: mvaughan

Comment 3

4 years ago
This issue does not reproduce on the 01/23/14 1.1 build.

This issue appears to have started reproducing on the 07/31/13 1.2 build.

- Works -
Device: Buri v1.2 MOZ RIL
BuildID: 20130730030200
Gaia: ba5ff211fbf6a930326cc6a0d4a1205a7528630b
Gecko: 3d40d270c031
Version: 25.0a1
RIL Version:
Firmware Version: V1.2-device.cfg

- Broken -
Device: Buri v1.2 MOZ RIL
BuildID: 20130731030205
Gaia: 9bfceaa90e8b92a379432b67121afa3cd3f14c90
Gecko: c2b375f3a909
Version: 25.0a1
Firmware Version: V1.2-device.cfg
Keywords: qawanted → regression
Can I get a video of the bug?
Keywords: qawanted
(Reporter)

Comment 5

4 years ago
I previously posted the video in comment 1 as the file size was too big, here is the link to the video:

http://www.youtube.com/watch?v=V3F4UXFtjUI

Updated

4 years ago
Keywords: qawanted
(In reply to Josh Schmitt from comment #5)
> I previously posted the video in comment 1 as the file size was too big,
> here is the link to the video:
> 
> http://www.youtube.com/watch?v=V3F4UXFtjUI

The video here cutting off the top of the phone. Can you include a video shows the whole phone while the bug is reproducing?
Keywords: qawanted
(Reporter)

Comment 7

4 years ago
I have uploaded a new video file to youtube.com here is the link http://www.youtube.com/watch?v=X2T6kzto2BM
(Reporter)

Updated

4 years ago
Keywords: qawanted
Okay, this is bad. We're losing the address bar & tab management after the embarrassing page appears.
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → 1.3+
Whiteboard: dogfood1.3 → dogfood1.3 [systemsfe]
Ben, please take a look.
Thanks!
Assignee: nobody → bfrancis
(Assignee)

Comment 10

4 years ago
Created attachment 8366902 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/15782

The issue is that if the address bar is hidden when a tab crashes, it is not shown again when the user closes the tab from the crash screen, thereby selecting another tab or creating a new tab at the start screen.

This fix always shows the address bar when a different tab is selected, because there are other cases where this could happen too.
Attachment #8366902 - Flags: review?(dale)
(Assignee)

Comment 12

4 years ago
Thanks Dale.

Merged into master https://github.com/mozilla-b2g/gaia/commit/d9d9d46a980bcabcc61a8239dbff77bd0ae8f559
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
doh sorry I meant to resolve / link and got lost
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 d9d9d46a980bcabcc61a8239dbff77bd0ae8f559
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(bfrancis)
(Assignee)

Comment 15

4 years ago
It seems that what happened was that Dale cherry picked the commit to master rather than merged it. I didn't notice this and merged the pull request, which then added an empty commit.

So in fact the commit which needs uplifting is ac0692fcd9bc59508dc978591cc380f8dcdc7873 which contains the actual change.

I have uplifted this to 1.3 in 96b1d945027d9122359109a5ac230f0ede6bfd7b
status-b2g-v1.3: affected → fixed
Flags: needinfo?(bfrancis)
(Assignee)

Updated

4 years ago
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.