[Calender] User cannot create events that repeat and span across multiple days

RESOLVED DUPLICATE of bug 931983

Status

RESOLVED DUPLICATE of bug 931983
5 years ago
5 years ago

People

(Reporter: pfield, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.2 affected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3)

Attachments

(1 attachment)

8.08 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 8364609 [details]
log.txt

Description: 
There is no way for the user to repeat similar events, resulting in events that span multiple days being shown as "all day events" rather than events on separate days with similar times.

Repro Steps:
1) Updated Buri to Build ID: 20140113004002.
2) Open calender application.
3) Create an event that spans multiple days, at least 3, and covers several hours. (DO NOT CHECK THE ALL DAY OPTION.)
4) Go into the "month" and "week" view of the events. 
5) Observe the days the events spanned.
 
Actual: 
There is no way to repeat like events that span multiple days, instead one event spanned over multiple days encompasses "all day" of each day in between the start/end date.

Expected: 
User is able to set like events. (I.E: 1pm - 5pm;  Monday - Friday.)

Environmental Variables
Device: Buri v 1.3.0 COM RIL
Build ID: 20140121004137
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 5/5 

See attached: Video - logcat
Video shows what events that span multiple days looks like without the ability to repeat like times.
Log shows what occurs when the user tries to set and event that spans multiple days.
(Reporter)

Comment 1

5 years ago
Video was too large, linking url to youtube video.

https://www.youtube.com/watch?v=x2olY9y40AE&feature=youtu.be
status-b2g-v1.2: --- → affected
status-b2g-v1.3: --- → affected
(Reporter)

Comment 2

5 years ago
This issue occurs in Buri V1.2

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20140121004053
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/c9f305c1d9a7
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2-device.cfg
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 931983
You need to log in before you can comment on or make changes to this bug.