Closed Bug 963269 Opened 7 years ago Closed 7 years ago

Regression: Tabs opened in the background never fetch their site favicon

Categories

(Firefox for Android :: General, defect)

29 Branch
x86
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- affected

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: regression, reproducible)

Currently on my Samsung Galaxy Tab 3 10" (Android 4.2), loading tabs in the background all fail to fetch their favicon

E/LoadFaviconTask(11311): Error reading favicon
E/LoadFaviconTask(11311): 	at org.mozilla.gecko.favicons.LoadFaviconTask.tryDownloadRecurse(LoadFaviconTask.java:124)
E/LoadFaviconTask(11311): 	at org.mozilla.gecko.favicons.LoadFaviconTask.downloadAndDecodeImage(LoadFaviconTask.java:222)
E/LoadFaviconTask(11311): 	at org.mozilla.gecko.favicons.LoadFaviconTask.downloadFavicon(LoadFaviconTask.java:201)
E/LoadFaviconTask(11311): 	at org.mozilla.gecko.favicons.LoadFaviconTask.doInBackground$2d4c763b(LoadFaviconTask.java:370)
E/LoadFaviconTask(11311): 	at org.mozilla.gecko.favicons.LoadFaviconTask.doInBackground$42af7916(LoadFaviconTask.java:42)


Literally every site I open in the background fails to fetch a favicon.
/me summons ckitching
Flags: needinfo?(chriskitching)
I can't reproduce this on trunk...
My approach has been to do a search (To obtain links to sites for which there is no cached favicon) and then use the open in new tab function to load the tabs in the background. The error you report doesn't show up, and the icon has loaded when I look at the tab.
That's annoying.

Am I doing this wrongly? Can (did) you reproduce this on a current build?
Nightly (01/23). Tomorrow, I'll double-check from startup how I might have gotten into that state.
On the other hand, I did run into an instance of the joyous interaction between Bug 914952 and Bug 914027. (Namely, a site provides multiple favicons, the first one is undecodeable (SVG), the second one is not, but is never processed.).
Sadface.

Favicons are not as simple as they seem. :P
Flags: needinfo?(chriskitching)
I'll re-open if I run into this again. I tried re-tracing my steps, just went over to HN and began opening a bunch of articles in the background. No issues today; yesterday, each site was hitting that error in comment #0.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.