Rows in tables overlap/overlay other rows in table.

RESOLVED FIXED in mozilla0.9.6

Status

()

Core
Layout: Tables
--
major
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: riscky, Assigned: karnaze (gone))

Tracking

({dataloss, testcase})

Trunk
mozilla0.9.6
dataloss, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PATCH CANDIDATE_094, URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.3+) Gecko/20010821
BuildID:    2001082105

I will have an attached image to show the exact problem.

Entire rows from the main table that contains 'news' stories overlap other rows
that contain news stories. Refreshing the page does resolve the issue.

Reproducible: Always
Steps to Reproduce:
1.Clear memory and disk cache
2.Visit fark.com
3.Scroll down page looking for blank areas between news stories.
4.Next story has overlapping text from the blank area as well as the text that
should appear in that row.

Actual Results:  Overlapping rows in table

Expected Results:  one flat smooth table. refresh page to see expected results.

Thinking that this might be a dup of bug 82946 however since the build I am
using 2001-08-21 (os x trunk build) is new as of today and the patch and fix for
bug 82946 has been in since 2001-08-07 either this is a new bug or bug 82946 is
not fixed.
(Reporter)

Comment 1

17 years ago
Created attachment 46672 [details]
screen shot of broswer showing bug

Comment 2

17 years ago
Reporter could you check tomorrow again this bug as Chris Karnaze checked in a
patch that should fix this problem.
(Reporter)

Comment 3

17 years ago
trunk build 2001-08-22-05 (mac os x)

Issue still exist... will attack screen shot
(changing the size of the browser window fixes the overlapping text.
(Reporter)

Comment 4

17 years ago
Created attachment 46765 [details]
todays confirmation that bug still exist

Comment 5

17 years ago
Confirming using Mac/2001082208 on Mac OS 9.1. The problem doesn't occur using Mac/
2001080214 (0.9.3), though.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
There is at least some evangelism part to this bug, though. The HTML in question is 
riddled with errors, mostly involving FORM elements inside TABLE or TR elements where 
they don't belong. Attaching version of their page made valid and well-formed.

Comment 7

17 years ago
Created attachment 46914 [details]
HTML made valid and well-formed does not exhibit problem
(Assignee)

Comment 8

17 years ago
I'm seeing the problem on the trunk but not the m0.9.2 branch. I tried canceling 
the patch in bug 89315, but it didn't make any difference. Could this be a 
parser issue? We need a reduced test case.
Severity: normal → major
Keywords: dataloss, qawanted
Hardware: Macintosh → All
Target Milestone: --- → mozilla0.9.5

Comment 9

17 years ago
If this bug is Mac specific please change platform to Macintosh from All

Comment 10

17 years ago
Created attachment 47935 [details]
Testcase
Keywords: testcase
(Assignee)

Comment 11

17 years ago
I'm not seeing the problem on a 9/4/1 debug Win2K trunk build. Since the 
platform was changed to mac, reassigning to attinasi.
Assignee: karnaze → attinasi
Keywords: qawanted

Comment 12

17 years ago
*** Bug 101010 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 100073 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 96371 has been marked as a duplicate of this bug. ***

Updated

17 years ago
OS: MacOS X → All

Comment 15

17 years ago
I filed bug 100073 for this problem on Linux (so its not Mac specific).
Problem still exists in build 2001091908.

Comment 16

17 years ago
Chris, I'm seeing the problem in the testcase on the 9-20 0.9.4 build. Can you
take a look? Bounce as necessary, of course.
Assignee: attinasi → karnaze
I'm not sure if this is the same bug or not, but you can see the same
effect (massive table overlapping) about halfway down the page at
<http://www.amurgsval.org/shadowrun/learning.html>.

The W3C validator has no complaints about the table structure of this
page (it does bitch a lot about numeric entities and improper nesting of
<H2> inside <A> etc).
(Assignee)

Comment 18

16 years ago
Created attachment 51762 [details] [diff] [review]
patch to fix the bug
(Assignee)

Comment 19

16 years ago
Zack, http://www.amurgsval.org/shadowrun/learning.html appears to be a different 
bug since the patch does not fix it. Could you please open a new bug with 
the dataloss keyword.
Status: NEW → ASSIGNED

Comment 20

16 years ago
Comment on attachment 51762 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Attachment #51762 - Flags: superreview+

Comment 21

16 years ago
Comment on attachment 51762 [details] [diff] [review]
patch to fix the bug

r=alexsavulov

Updated

16 years ago
Attachment #51762 - Flags: review+
(Assignee)

Updated

16 years ago
Keywords: patch
(Assignee)

Comment 22

16 years ago
reassigning to m0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Keywords: nsbranch
Marking nsbranch-. Not "Stop Ship"
Keywords: nsbranch → nsbranch-
(Assignee)

Updated

16 years ago
Keywords: patch
Whiteboard: PATCH
(Assignee)

Comment 24

16 years ago
*** Bug 100333 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

16 years ago
The patch is in.
Whiteboard: PATCH → PATCH CANDIDATE_094
(Assignee)

Comment 26

16 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 27

16 years ago
*** Bug 96321 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
Ok still getting problems with 
http://www.amurgsval.org/shadowrun/learning.html
Was there ever a bug created for this? I can't find it.
There are also some weird spacing bug in
http://direct.mwave.com/mwave/ProdMM-SS-CRE.hmx
reload from center of page a few times to see. Anyways, seperate bugs. Will file
seperates in the morning, yawn.

Comment 29

16 years ago
*** Bug 107335 has been marked as a duplicate of this bug. ***

Comment 30

16 years ago
*** Bug 108080 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
*** Bug 109369 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
*** Bug 110707 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.