Closed Bug 963508 Opened 6 years ago Closed 6 years ago

java.util.ConcurrentModificationException: at java.util.HashMap$HashIterator.nextEntry(HashMap.java) at org.mozilla.gecko.NotificationHelper.clearAll

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed
fennec 28+ ---

People

(Reporter: lucasr, Assigned: lucasr)

References

Details

Crash Data

Attachments

(1 file)

22564ed2-24f1-480a-b9df-ab8652140124

java.util.ConcurrentModificationException
	at java.util.HashMap$HashIterator.nextEntry(HashMap.java:792)
	at java.util.HashMap$KeyIterator.next(HashMap.java:819)
	at org.mozilla.gecko.NotificationHelper.clearAll(NotificationHelper.java:280)
	at org.mozilla.gecko.NotificationHelper.destroy(NotificationHelper.java:287)
	at org.mozilla.gecko.GeckoApp.onDestroy(GeckoApp.java:2082)
	at org.mozilla.gecko.BrowserApp.onDestroy(BrowserApp.java:826)
	at android.app.Activity.performDestroy(Activity.java:5436)
	at android.app.Instrumentation.callActivityOnDestroy(Instrumentation.java:1127)
	at android.app.ActivityThread.performDestroyActivity(ActivityThread.java:3525)
	at android.app.ActivityThread.handleDestroyActivity(ActivityThread.java:3556)
	at android.app.ActivityThread.access$1300(ActivityThread.java:150)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1333)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:5279)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1102)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:869)
	at dalvik.system.NativeStart.main(Native Method)

https://crash-stats.mozilla.com/report/list?product=FennecAndroid&signature=java.util.ConcurrentModificationException%3A+at+java.util.HashMap%24HashIterator.nextEntry%28HashMap.java%29
tracking-fennec: --- → ?
This is
Comment on attachment 8364996 [details] [diff] [review]
Don't directly remove elements while iterating on a set (r=wesj)

Top crasher (#3) in Fx27.
Attachment #8364996 - Flags: review?(wjohnston)
Duplicate of this bug: 960148
Attachment #8364996 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/f42011b2ec5b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
tracking-fennec: ? → 28+
Comment on attachment 8364996 [details] [diff] [review]
Don't directly remove elements while iterating on a set (r=wesj)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 882136
User impact if declined: Top crasher #3 in Fx27
Testing completed (on m-c, etc.): landed, no issues found.
Risk to taking this patch (and alternatives if risky): Pretty, just avoids removing items while iterating the list.
String or IDL/UUID changes made by this patch: n/a
Attachment #8364996 - Flags: approval-mozilla-aurora?
Comment on attachment 8364996 [details] [diff] [review]
Don't directly remove elements while iterating on a set (r=wesj)

Go ahead!
Attachment #8364996 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.