[Contacts][WebIDL] Array copy strange behavior

RESOLVED INVALID

Status

()

Core
DOM: Contacts
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: gtorodelvalle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

OK, so this bug popped up when solving bug 960525 so I would recommend taking a look at it to start with ;-)

In fact, all the info I have about the issue is detailed in https://bugzilla.mozilla.org/show_bug.cgi?id=960525#c9 but trying to sum it up: it seems we have an issue when copying properties of a contact which are an Array of at least one null ([null]) or undefined entry ([undefined]).

If you need further information, please do not hesitate to need-info me ;-) Thanks!
Hi Julien, could you shed some light on this or maybe recommend me someone to need-info about it? :) Thanks!
I think the behavior you're seeing there is the (expected) stringification of the element, so [null] becomes ["null"], etc. The real question is how you're getting the [null] array there, if that object is also a mozContact. I commented in the other bug as well.
So I guess we should close this bug as RESOLVED - WONTFIX? Waiting for Reuben's confirmation before doing it :-) Thanks!
Flags: needinfo?(reuben.bmo)
Looks like it, according to the explanation in bug 960525.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(reuben.bmo)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.