Closed Bug 963673 Opened 8 years ago Closed 8 years ago

[E.me] Attempting to add a "custom" smart collection does nothing

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.2 unaffected, b2g-v1.3 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- affected

People

(Reporter: pfield, Unassigned)

Details

(Keywords: regression, Whiteboard: dogfood1.3)

Attachments

(2 files)

Attached file CustomSmartlog.txt
Description: 
If the user attempts to add a "custom" smart collection, nothing will happen. When naming 

Repro Steps:
1) Updated Buri to Build ID: 20140121004137.
2) Long press on the background until the prompt appears.
3) Select "add Smart Collections."
4) Attempt to add "Custom" smart collection.
 
Actual: 
Attempting to add a smart collection with "Custom" does not function.

Expected: 
Adding a smart collection with "custom" prompts the user to name a custom collection and then does so accordingly.

Environmental Variables
Device: Buri v 1.3.0 COM RIL
Build ID: 20140121004137
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Platform Version: 28.0a2
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 5/5 

See attached: Video - logcat
There does not appear to be a way to add custom smart collections on 1.2, therefore this issue does not occur on Buri 1.2

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20140121004053
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/c9f305c1d9a7
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2-device.cfg
I know this was working on an earlier 1.3 build.
blocking-b2g: --- → 1.3?
Component: Gaia::Everything.me → Gaia::Homescreen
Hi all, 

   Is this commit https://github.com/mozilla-b2g/gaia/commit/a15974a80d6b93a23054caaa5c8641c5e317db51 in your build? It looks like a problem with modal dialogs like bug 960659 thought

Thanks
Well, I was talking about v1.3, is collection feature available in v1.2? I think that it is not available there (I don't know if I am wrong)
Component: Gaia::Homescreen → Gaia::Everything.me
Flags: needinfo?(ran)
OK, Ran forget my last comment 4, I got insane :)

My commit [1] (comment 3) is not available when you tested it. Please update your build and test again. Thanks a lot

[1] https://github.com/mozilla-b2g/gaia/commit/a15974a80d6b93a23054caaa5c8641c5e317db51
Flags: needinfo?(ran)
(In reply to Cristian Rodriguez (:crdlc) from comment #4)
> Well, I was talking about v1.3, is collection feature available in v1.2? I
> think that it is not available there (I don't know if I am wrong)

Collections are new in v1.3 feature, not available in v1.2.

My guess is that Crisitian is right since the 'Custom Collection' feature uses a native prompt dialog:
https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/everything.me/modules/CollectionsSuggest/CollectionsSuggest.js#L54
QA Wanted to retest on the latest 1.3 build.
Issue does not reproduce on latest nightly v1.3, user is able to create a new custom Smart Collection as expected.

v1.3 Environmental Variables:
Device: buri v1.3 MOZ
BuildID: 20140127004002
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Gecko: c40099a42c1f
Version: 28.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: pbylenga
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.