XBL can't override DOM methods/properties.

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: hyatt, Assigned: jst)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xbl1.0], URL)

(Reporter)

Description

17 years ago
Looks like XBL is unable to override DOM methods/properties.  Go to the test 
case at the above URL, and click on the "Load Mozilla.Org" button.  You should 
see mozilla.org load in the iframe underneath the button.

It doesn't.  Looks like the XPC prototype doesn't know about the DOM 
methods/properties.
(Reporter)

Updated

17 years ago
Keywords: regression
Whiteboard: [xbl1.0]
(Reporter)

Comment 1

17 years ago
Just give me a way to do this... that's all I need... I'm willing to deal with 
a custom syntax or something other than what I'm doing as long as there is a 
way.
Where are those properties, then (methods are just function-valued props)?  Are
they perhaps directly on the element's js object?  hyatt, what does
x.hasOwnProperty('getAttribute') return for an element x?

/be
(Reporter)

Comment 3

17 years ago
Well, I can see that XBL's setAttribute method got called, so technically my
method *is* overriding.  It just has no way of calling its base method that I
can discover.
(Reporter)

Comment 4

17 years ago
jband educated me.  You can use "apply" or "call" and this works just fine.  
Just another invalid bug filed by me. ;)

Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
verify
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.