Memory leak of 8192 bytes from 1 block allocated in nsImapProtocol::nsImapProtocol(void)

VERIFIED DUPLICATE of bug 96387

Status

VERIFIED DUPLICATE of bug 96387
17 years ago
10 years ago

People

(Reporter: stephend, Assigned: mscott)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

Build ID:  2001-08-21-09, Windows 2000.  Using Purify, I found:

MLK: Memory leak of 8192 bytes from 1 block allocated in
nsImapProtocol::nsImapProtocol(void)
        Distribution of leaked blocks
              8192 bytes from 1 block of 8192 bytes (0x0f01b050) 
        Allocation location
            PR_Calloc+0x31       [.\../../../../pr/src/malloc/prmem.c:59
ip=0x30018cb1]
            nsImapProtocol::nsImapProtocol(void)+0xa7f
[c:\moz_src\mozilla\mailnews\imap\src\nsImapProtocol.cpp:272 ip=0x08b9bc19]
            nsImapProtocolConstructor+0x73
[c:\moz_src\mozilla\mailnews\imap\build\nsImapFactory.cpp:39 ip=0x08b91965]
            nsGenericFactory::CreateInstance(nsISupports *,nsID const&,void *
*)+0x50 [c:\moz_src\mozilla\xpcom\components\nsGenericFactory.cpp:59 ip=0x100a60e8]
            nsImapIncomingServer::CreateProtocolInstance(nsIEventQueue
*,nsIImapProtocol * *)+0x83
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:739 ip=0x08bc9cbf]
            nsImapIncomingServer::CreateImapConnection(nsIEventQueue
*,nsIImapUrl *,nsIImapProtocol * *)+0x8c6
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:709 ip=0x08bc9b02]
            nsImapIncomingServer::GetImapConnectionAndLoadUrl(nsIEventQueue
*,nsIImapUrl *,nsISupports *)+0x97
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:426 ip=0x08bc81fe]
            nsImapService::GetImapConnectionAndLoadUrl(nsIEventQueue
*,nsIImapUrl *,nsISupports *,nsIURI * *)+0x314
[c:\moz_src\mozilla\mailnews\imap\src\nsImapService.cpp:2289 ip=0x08be9465]
            nsImapService::SelectFolder(nsIEventQueue *,nsIMsgFolder
*,nsIUrlListener *,nsIMsgWindow *,nsIURI * *)+0x51d
[c:\moz_src\mozilla\mailnews\imap\src\nsImapService.cpp:403 ip=0x08bdbf0a]
            nsImapMailFolder::UpdateFolder(nsIMsgWindow *)+0x622
[c:\moz_src\mozilla\mailnews\imap\src\nsImapMailFolder.cpp:628 ip=0x08bf249d]
Seems like a DUP of bug 96387...(no, I'm not dislexic ;-)

*** This bug has been marked as a duplicate of 96387 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
After confirm with Stephen. Verified as Dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.