All users were logged out of Bugzilla on October 13th, 2018

MLK: Memory leak of 24576 bytes from 3 blocks allocated in PR_Calloc

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: stephend, Assigned: Bienvenu)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

Build ID:  2001-08-21-09, Windows 2000, using Purify

[W] MLK: Memory leak of 24576 bytes from 3 blocks allocated in PR_Calloc
        Distribution of leaked blocks
        Allocation location
            calloc+0xc           [C:\WINNT\SYSTEM32\msvcrt.DLL ip=0x5800122b]
            PR_Calloc+0x31       [.\../../../../pr/src/malloc/prmem.c:59 
ip=0x30018cb1]
            nsImapProtocol::nsImapProtocol(void)+0xb3e 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapProtocol.cpp:276 ip=0x08b9bcd8]
            nsImapProtocolConstructor+0x73 
[c:\moz_src\mozilla\mailnews\imap\build\nsImapFactory.cpp:39 ip=0x08b91965]
            nsGenericFactory::CreateInstance(nsISupports *,nsID const&,void * *)
+0x50 [c:\moz_src\mozilla\xpcom\components\nsGenericFactory.cpp:59 
ip=0x100a60e8]
            nsImapIncomingServer::CreateProtocolInstance(nsIEventQueue 
*,nsIImapProtocol * *)+0x83 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:739 
ip=0x08bc9cbf]
            nsImapIncomingServer::CreateImapConnection(nsIEventQueue 
*,nsIImapUrl *,nsIImapProtocol * *)+0x8c6 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:709 
ip=0x08bc9b02]
            nsImapIncomingServer::GetImapConnectionAndLoadUrl(nsIEventQueue 
*,nsIImapUrl *,nsISupports *)+0x97 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapIncomingServer.cpp:426 
ip=0x08bc81fe]
            nsImapService::GetImapConnectionAndLoadUrl(nsIEventQueue 
*,nsIImapUrl *,nsISupports *,nsIURI * *)+0x314 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapService.cpp:2289 ip=0x08be9465]
            nsImapService::SelectFolder(nsIEventQueue *,nsIMsgFolder 
*,nsIUrlListener *,nsIMsgWindow *,nsIURI * *)+0x51d 
[c:\moz_src\mozilla\mailnews\imap\src\nsImapService.cpp:403 ip=0x08bdbf0a]
*** Bug 96378 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 92580
QA Contact: huang → stephend
(Assignee)

Comment 2

17 years ago
taking - I bet this is fixed now that we don't leak nsImapProtocol objects as much.
Assignee: mscott → bienvenu
Yeah, I think so too, I'll have to keep a close watch on this in the Purify logs...
(Assignee)

Comment 4

17 years ago
marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
I filed this with no steps to reproduce, so since I've verified previously the 
nsImapProtocol leak, I'm going to verify this one, and re-file with better 
clarification.

Verified FIXED.
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 92580
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.