leave mail on server option does not work

VERIFIED WORKSFORME

Status

MailNews Core
Networking: POP
--
minor
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Bernd Sowislo, Assigned: Navin Gupta)

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
Environment Openvms, Mozilla (0.9.3) Mail, loading mail from POP server.
If you set the server option: leave mail on server, every time you get the mail,
the same mails are downloaded again.This bug is not in version 0.9.2. Solution
step back to version 0.9.2 or delete messages on server

Comment 1

16 years ago
I have just tried to reproduce this on my OpenVMS M0.9.3 release and I
am unable to. With the "leave mail on server" option checked (regardless
of the "delete messages on server when they are deleted locally" setting),
each message is only downloaded once.

Can you please post exact steps to reproduce this problem.

Comment 2

16 years ago
Via email to me:

> we have installed Build ID: 2001080116 here are the steps:
> 1. open the mail window
> 2. select edit, Mail/News Account settings... Server settings
> 3. port 110 set only Leave messages on server all other options left blank
> 4. press ok.
> 
> whenever you press Get Msg the same mails are downloaded. this is 
> reproduceable, whenever I try (the version before worked correctly at 
> this point)

I have just tried with EXACTLY these steps, and the mails only come down
once. I can read them, delete them, empty the trash, and still they will NOT
come down a second time. By telneting to the POP3 server I can see that the
mails ARE still there.

I have no idea why this isn't working for you. The strange thing is that you
say it WAS working until M0.9.3.

Can some mail developer tell us what changed in this area for M0.9.3 that
might be causing this???

Comment 3

16 years ago
Reporter via email:

> now I have deinstalled version 9.2, deleted the path 
> sys$login:[_mozilla...],
> rebooted and installed the version 9.3  again.  All previous emails are 
> lost,
> the feature: leave mail on server works ok, all messages are transferred 
> only once as in your tests
> 
> thanks for your support

So whatever was causing this problem, deleting your profile fixed it. It would
probably have been useful to have looked at your old profile, particularly at
the prefs, in case there was a clue there. Did you really DELETE, or just
RENAME?

[by the way, can you reply via bugzilla, instead of via mail]

Comment 4

16 years ago
I see (via mail) that you have managed to reproduce the problem. Do you 
remember doing anything special to cause this problem to occur? At what point
did it start to fail?

Here's a thought. You're not running TWO instances of Mozilla from the 
same (SYSTEM) account and profile, are you?

Comment 5

16 years ago
Bernd sent me his directory, and sure enough, if you search for message-id's
in INBOX, this is what you find:

Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>
Message-ID: <3B83E0FA.7040700@t-online.de>
Message-ID: <3B83DF4B.4010607@t-online.de>
Message-Id: <200108221455.HAA13950@mothra.mozilla.org>

Notice all the dups. So it really does already have the message when it
downloads it again.

Comment 6

16 years ago
Reporter, 
Does leave mail on server option work for you after creating a new profile?  I
see that you mention in one of the comments below.  

Comment 7

16 years ago
From the reporter, via email:

> now I have restored  the previous version (ID 2001063010) and rebooted 
> the system
> The problem is still there
> so it seems it is independend from the version 9.2 or 9.3. While 
> updateing a week ago I have
> deleted to whole path sys$login:[.mozilla]. Is it possible that the 
> number of the latest
> mail fetched from to mail server is stored in one file and read from 
> another file? should I delete the
> whole path again (that would delete my mail entries)?

If you delete your sys$login:[.mozilla] tree then you will lose all your 
mails. 

I would expect that if you delete your sys$login:[.mozilla] tree that the
mails which are still on the remote server would be downloaded again when
you next connect to the POP3 server. But this should only happen once.

IMPORTANT QUESTION: Are you running more than one instance of Mozilla
at the same time for the same account (SYSTEM in your case)????

Please report back HERE via Bugzilla, not via mail. Thanks.
(Reporter)

Comment 8

16 years ago
Hi,
Your first question: only one instance of mozilla is active.

it is normal, that after deleting of the profile [._mozilla...] all mails
are downloaded again. But when the problem occures, every time I press
Get Msg the same mail(s) are downloaded, and I have as many identical mails in
my inbox as I press the Get Msg button. I think, the problem is reproducable:
If I delete the profile after quitting mozilla (deleting while mozilla is active
leaves many locked files) the problem is still there after starting mozilla
If I delete the path, reboot the system and invoke mozilla then all works ok

Comment 9

16 years ago
reporter,
Which pop server are you using? Can you create pop protocol log and attach it to 
the bug.  Here is the instructions on how to get a log.  
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Replace pop3 for imap.  
(Reporter)

Comment 10

16 years ago
Hi,
pop server pop.t-online.de
smtp mailto.t-online.de

in your documentation OpenVms is not described, do you use symbols or logicals?
I will send you to whole defective path as VMS backup file if
you like please give me your email address or a path on your fileserver
(for ftp copy)

regards

Comment 11

16 years ago
Just use logicals on OpenVMS. Like this:

  $ DEFINE NSPR_LOG_MODULES POP3:5
  $ DEFINE NSPR_LOG_FILE DKA0:[COLIN]POP3.LOG
  $ @SYS$COMMON:[MOZILLA]MOZILLA

Then post the contents of the log file back here via the "create a new
attachment" link on the bugzilla page.

Comment 12

16 years ago
Just to clarity what we'd like to see logged:

  - Make sure you have no new mails
  - Exit Mozilla
  - Send yourself a mail from some place
  - Define the logging logicals
  - Start Mozilla
  - Download the mail message
  - Exit Mozilla - you now have log file #1

  - Enter Mozilla again
  - Click the "get mail" icon
  - Exit Mozilla - you now have log file #2

Attach the 2 log files to this bug report.

One last thing. Make sure that each time you start Mozilla the file you
defined in NSPR_LOG_FILE does NOT exist.
(Reporter)

Comment 13

16 years ago
Created attachment 47006 [details]
first download of   test my account
(Reporter)

Comment 14

16 years ago
Created attachment 47007 [details]
second download of    test my account

Comment 15

16 years ago
Thanks for the attachments. That's exactly what's needed. I see that in both 
logs the UIDL of the mail being downloaded is identical. So why does Mozilla 
download it a second time? The mail experts will have to provide some pointers 
for that one.

Out of interest, what version of OpenVMS are you running? 
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 16

16 years ago
the bug occures in OVMS Version 7.2 1H1 

Comment 17

16 years ago
Hmm, I'm not Mozilla mail expert, so I don't know if this is relevant or not. 
But when I download mail from my POP3 server, I have an X-UIDL line that 
contains the same UIDL that is seen in response to the initial UIDL command. But 
I don't see the X-UIDL line in the logs from Bernd. Relevant? The X-UIDL line 
isn't how Mozilla keeps track of what its got, is it?

Comment 18

16 years ago
Looks like popstate.dat keeps track of what its read by storing the UIDL's in 
there. Bernd, can you post the contents of you popstate.dat file? You'll find it 
in your _MOZILLA tree.

Comment 19

16 years ago
If we don't see 5be9af4abba16c6b in your popstate.dat file, then that's why the
mails keep coming down.
(Reporter)

Comment 20

16 years ago
Created attachment 47013 [details]
all three files in one file please look for **** entries

Comment 21

16 years ago
Interesting. Can you download the mail a third time and post the popstate.dat
file again.
(Reporter)

Comment 22

16 years ago
Created attachment 47016 [details]
together with your two mails, get msg pressed 10 times

Comment 23

16 years ago
After pressing GET MESSAGE 10 times, how many times was each mail downloaded?
2 or 10?
(Reporter)

Comment 24

16 years ago
10 times 3 mails -> 30
(Assignee)

Comment 25

16 years ago
You have the hostname and username entries twice in your popstate.dat file
which is not correct. Did you edit your popstate.dat file. Also can 
you try to reproduce this using new profile and if not successful again
please attach the popstate.dat. 

In popstate.dat we keep the uidl entries to keep track of what messages have 
been downloaded and the state of each message. 
(Reporter)

Comment 26

16 years ago
Hi
meanwhile I have two pathes so I can switch (renaming from
_mozilla_defective.dir to _mozilla.dir and vice versa) between the correct one
and the defect one.I did not edit any file (except appending them into a single
one). I have seen that the defect tree contains the popstate.dat with two
entries. So I copied the file with the two entries into the correct path. The
application works still correctly filling
the file the the new ID's I try the other way using the correct popstate.dat
in the defect path and tell you what happens..........

Comment 27

16 years ago
Can you do a DIR /FULL on your popstate.dat file and post the output here?

Comment 28

16 years ago
reporter,
Is this still problem on new profile with the latest build. If not please 
comment so this bug can be resolved.

Comment 29

16 years ago
I just received email from Bernd, this is no longer a problem for him.

Marking bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 30

16 years ago
verifying this as w4me based on the comments below
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.