Closed Bug 963946 Opened 8 years ago Closed 8 years ago

Fix theme regressions from bug 963739

Categories

(Thunderbird :: Theme, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: jsbruner, Assigned: jsbruner)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached patch Fix. (obsolete) β€” β€” Splinter Review
So this fixes the problem by actually completely removing the border on #quick-filter-bar-main-bar and uses the one from #quick-filter-bar-expando instead.

This also makes it look like the expando bar is part of the main bar, which is pretty nice.

I did have to mess with some margins though to make things line up.
Attachment #8365551 - Flags: review?(richard.marti)
Comment on attachment 8365551 [details] [diff] [review]
Fix.

Review of attachment 8365551 [details] [diff] [review]:
-----------------------------------------------------------------

Except the nit the code looks good.
But try this: Be sure one of the filtered messages has a tag. Enter something into QFB search field, now press the tag button.
Result: By pressing the tag button the quick-filter-bar-expando grows because the qfb-boolean-mode menulist has to much margin.

::: mail/themes/osx/mail/quickFilterBar.css
@@ +79,5 @@
>    text-shadow: 0 1px 0 rgba(255, 255, 255, 0.4);
>    height: 16px;
>    font-weight: bold;
>    padding: 0 4px;
> +  margin: 0px 3px 0px;

Nit: margin: 0px 3px; would be enough.
Attachment #8365551 - Flags: ui-review-
Attachment #8365551 - Flags: review?(richard.marti)
Attachment #8365551 - Flags: review+
Attached patch Fix. r=Paenglab β€” β€” Splinter Review
Made changes.
Attachment #8365551 - Attachment is obsolete: true
Attachment #8365699 - Flags: review+
https://hg.mozilla.org/comm-central/rev/675bc914df2c
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
You need to log in before you can comment on or make changes to this bug.