Browser JAva plug-in download fails / browser will not use installed JRE

VERIFIED DUPLICATE of bug 94790

Status

()

--
critical
VERIFIED DUPLICATE of bug 94790
17 years ago
17 years ago

People

(Reporter: jvrijn, Assigned: edburns)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi,

First of all the system:
- AMD Athlon 1.2 GHz, 128 MB RAM
- Redhat Linux 7.1 running X11 and Gnome
- Browser Mozilla 0.9.3-1 + psm 0.9.3-1 installed through RPM
- Sun's JDK 1.3.1 installed

Scenario:
Step 1. While being root. On hitting an applet enabled page (java.sun.com) a
dialog box is presented asking permission to download the appropriate plug-in,
this is appoved.

Step 2. Mozilla downloads the Java 2 plugin from netscape and attempts an
install, the installation window dissapears, but on closing the browser anbd
re-opening it, a screen is presented that says something like "installation of
plug-in most complete....". I wait for ten minutes and try again, same result.

Step 3: Log-out and log-in as a different user, fire up Mozilla, hit a java
enabled page. The title bar of Mozilla is updated to display the title of the
page that contains the java applet, interaction with the browser impossible from
here on (menu's or links on the page do not respond).
Step 4: Uninstall Mozilla + psm and re-install. Going to preferences and
helpers. Configuring the local JRE as a helper for Mozilla. Go to java.sun.com
again, prompted for downloading the plug-in.

That's it. If you have questions about this bug, please feel free to contact me.

Best regards,

Jeroen

Comment 1

17 years ago
i got winME and have the same problem. only that it doesn't even show that error
message. i click on the java applet field, install the plugin and then no matter
if i restart mozilla or not, it says "click here to install plugin" again.

Comment 2

17 years ago
Reporter, are you by any chance seeing bug 84896?

Comment 3

17 years ago
oji
Assignee: av → edburns
QA Contact: shrir → pmac
(Reporter)

Comment 4

17 years ago
Ok, I admit I did not see bug 84896, which has a striking resemblence, however
this does not cover the whole story.

After having re-installed Mozilla and having reinstalled the Java plug-in,
taking in account bug 84896 and patiently waiting until xpicleanup disappeared,
which it did I start the browser again and go to java.sun.com. The browser hangs
immediately. It does display the HTML title in the title bar, but that's all.
After waiting minutes for the load to complete I have to kill the program.

At this stage, nothing in the UI works except for the window menu. The UI does
not re-paint itself, it appears dead.
(Reporter)

Comment 5

17 years ago
Furthermore, thinking this might be a version issue, I have downgraded to
Mozilla 0.9.2 and installed the java plug-in again. Unfortunately I still have
the same problem....

All I can think of now is that either the plug-in conflicts with the already
installed sun JSDK 1.3.1 or that Mozilla and the plug-in "talk" to eachother
through an IP socket that is blocked by the kernel firewall. Funny enough, I
also run Netscape Communicator 4.77 (don't like it) which has no problem with
it's Java plug-in....

Any ideas?

Comment 6

17 years ago
I think this might be a 94790 dup, marking it

*** This bug has been marked as a duplicate of 94790 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.