If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

typing about:addons opens duplicate addons manager. expected behavior should be like ctrl+shift+a

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: noitidart, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

i opened addons manager tab by pressing ctrl+shift+a,
then without closing this tab i went to another tab and hit ctrl+shift+a, it jumped me back to the first tab

i go to another tab and typed about:addons and hit enter and it opened a duplicate addon manager tab


Actual results:

duplicate addon manager tab opened


Expected results:

should have jumped me to that already opened addon manager tab. should match the behavior of ctrl+shift+a

Comment 1

4 years ago
[bugday-20140127]
Confirmed on Windows 7 firefox 29.0a1 (2014-01-26)that multiple addon tabs can be opened by entering "about:addons" in a new tab.
I can reproduce this issue with latest Nightly on XP 32-bit.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Isn't this the expected behaviour? I would expect that typing a URL in the Location Bar would open the page in question in the current tab, even if it is an about:something or chrome://something URL (a valid one of course) and even if it is already open in a different tab. In particular, I would expect either about:addons or chrome://mozapps/content/extensions/extensions.xul to open a fully functional add-ons manager in the current tab, regardless of whether there already is one in a different tab.

OTOH a menuitem or hotkey might, depending on the particular menu or key, act on the current tab, on a different (existing) tab, on a new tab, or on "none of the above".
P.S. I am seeing the same (IMHO expected) behaviour in SeaMonkey 2.27a1 (Toolkit 30.0a1) for Linux64, as follows:
Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 SeaMonkey/2.27a1 ID:20140208003001 c-c:68d3a6771ee3 m-c:cafe909f7e07
OS: Windows XP → All
Hardware: x86 → All
Version: 26 Branch → Trunk

Comment 5

2 years ago
I agree with comment 3.
I filed bug 1208208 and bug 1208222 to show how painful is that unwanted switching to opened tab in
real-life browsing. Currently it's possible to at least type url in a new tab to avoid switching.

Now I see that somebody finds that functionality desired, but still, it shouldn't be mandatory.
Ideally, there should be a way for user to get both types of behavior depending on what he wants.
Example: I can open a link in a new background/foreground tab if I hold Ctrl/Ctrl+Shift and click

But then again, urlbar already provides "Switch to tab" option, so here's nothing to "fix" (IMO)
The current behavior is consistent with about:preferences - I can't imagine why you'd want versions of the about: pages open in separate tabs, but they should work fine and show the state of the underlying system consistently (state of addons, prefs, etc) since they should be using observers and listeners consistently.

Unless there's a good reason I don't think it's worth changing this.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

10 months ago
Yep wontfix makes sense.
You need to log in before you can comment on or make changes to this bug.