[Sora][Browser]if you cancel the share notification ,you will find the interface On the left Load 2 times

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
5 years ago
9 months ago

People

(Reporter: sync-1, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

9.52 MB, video/3gpp
Details
(Reporter)

Description

5 years ago
Mozilla build ID: 20140118004001
 
 Created an attachment (id=615777)
 video
 
 DEFECT DESCRIPTION:
 [Browser]if you cancel the share notification ,you will find the interface On the left Load 2 times
  REPRODUCING PROCEDURES:
 1. launch "www.baidu.com"
 2. press share key to share the webpage
 3.cancel the notification which  if you are not set up to send or receive email
  EXPECTED BEHAVIOUR:
 it only load one times
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
This is because we're getting a desktop site rendered from baidu, which is not optimized for low memory devices, so we'll end up OOMing pretty easily. We need the mobile site rendered.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804642
(Reporter)

Comment 2

5 years ago
Created attachment 8366408 [details]
录像

Comment 3

5 years ago
Dear Jason

It is not a duplicate pr, in contack app, click email address at PERSONAL, will pop up a notification, after cancel, you will find the interface On the left Load 2 times
Indeed this has nothing to do with webpage rendering. This but can be reproduced with any website. The steps are:

1. Open browser and go to any website
2. Click the share icon
3. Cancel the "You are not set up to send or receive email, would you like to do that now" prompt.
4. You can see the screen bounce on the left side

Thanks

Vance
Flags: needinfo?(jsmith)
Ah, I see it now. Okay, reopening.
Status: RESOLVED → REOPENED
Flags: needinfo?(jsmith)
Resolution: DUPLICATE → ---
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
I see that shaking behavior in other issue too: https://bugzilla.mozilla.org/show_bug.cgi?id=970028

Not sure if they are of the same root cause. ni Alive for help here.

Personally i think this issue is quite annoying(well, it can happen on all the websites...), but not worth blocking 1.3
Flags: needinfo?(alive)
I don't think this blocks anything. It's an UI bug for the transition is wrong but in the end you get the correct app to be opened. This is difinitely not v1.3+ because there's a big change from 1.3 to 1.4 for transitioning and even on 1.4 it's not that easy to fix this. I could have a patch for current master but it is too risky to do the same thing in v1.3.
blocking-b2g: 1.3? → ---
Component: Gaia::Browser → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Assignee: nobody → alive

Comment 8

3 years ago
link all Fire C (codename: Sora) bugs to a meta one.
Blocks: 1258646

Comment 9

9 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.