MacOS X full-screen menubar makes tab bar inaccessible

RESOLVED DUPLICATE of bug 738335

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 738335
4 years ago
4 years ago

People

(Reporter: Decade, Unassigned)

Tracking

26 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

In the latest few versions of MacOS X, there is a full-screen mode. You click the arrow thing in the upper-right corner, and most of the OS stuff vanishes. When you move the mouse to the top of the screen, then the menu bar reappears.


Actual results:

The menubar then covers the Firefox tab bar, rendering it useless.


Expected results:

Safari sets a good example. When the mouse is brought to the top of the screen, it moves the tab bar and the tool bar down, so they are still accessible. It then keeps the menu bar down while the mouse is over the menu bar or over the tool bars, only sending those back up when the mouse leaves the bar areas entirely.

At least, having some way to access the tab bar while the menu bar is on-screen would be helpful.

Updated

4 years ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738335
You need to log in before you can comment on or make changes to this bug.