On screen mobile keyboard is hiding the HTML textarea when in focus

RESOLVED WORKSFORME

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WORKSFORME
4 years ago
2 months ago

People

(Reporter: cam.wernic, Unassigned)

Tracking

29 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8365836 [details]
testbasic.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I have a cheap Huawei Y210 smartphone (1GHz, 140MB RAM) running Android 2.3.6. It has the latest Firefox Mobile on it from the Google Play store. I'm trying to get a very basic webpage going which has a textarea on it. I have attached a test case.


Actual results:

Whenever I click into the textarea on the screen to enter text, the onscreen keyboard makes all the rendered HTML disappear off the screen and you can't see what is being typed (very frustrating).


Expected results:

It only appears to be happening on Firefox mobile. The inbuilt Android browser works fine. What I expect should happen is you can click in the text area, the cursor appears in the text area and you can type on the keyboard and see the text at the same time.

I have also tried a faster device Huawei Y320 (dual core 1.3GHz, 512MB RAM) running Android 4.2.2 and same version of Firefox. This also works fine. I think it may either be a problem with Firefox and this particular Android version.
Whiteboard: [dupme]
Is this a duplicate of bug 878375?
Closing this bug as worksforme since we do not have Firefox for Android 2.3.6 and because is not reproducible on Nexus 5(Android 6.0.1) and HTC 10(Android 8.1.0).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.