Closed Bug 964207 Opened 9 years ago Closed 9 years ago

Content gets vertically stretched while panning on a b2g phone without hardware home button and with home gesture enabled

Categories

(Core :: Panning and Zooming, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 962629

People

(Reporter: etienne, Unassigned)

Details

Attachments

(1 file)

STR: on a nexus 4
* enable the home gesture (in the developer settings) which disables the software home button and frees up some of the vertical real estate on the device
* in the browser, go to ihackernews.com
* tap the star and add to the homescreen
* open the newly created wrapper for ihackernews.com
* scroll

The contect scrolls but gets vertically stretch, then the hit target are way off.
Might be related to the window being taller than if the software home button was enabled.

(It doesn't reproduce on all websites, but systematically on this website, probably due to some weird onscroll hack)
Possibly dupe of bug 962629, but these STR sound better :)
I'd need to check with Etienne.
(In reply to Etienne Segonzac (:etienne) from comment #0)
> STR: on a nexus 4
> * enable the home gesture (in the developer settings) which disables the
> software home button and frees up some of the vertical real estate on the
> device
> * in the browser, go to ihackernews.com
> * tap the star and add to the homescreen
> * open the newly created wrapper for ihackernews.com
> * scroll
> 
> The contect scrolls but gets vertically stretch, then the hit target are way
> off.
> Might be related to the window being taller than if the software home button
> was enabled.
> 
> (It doesn't reproduce on all websites, but systematically on this website,
> probably due to some weird onscroll hack)

Can you attach a screenshot ?
Flags: needinfo?(etienne)
(In reply to Alexandre LISSY :gerard-majax from comment #3)
> Can you attach a screenshot ?

I tried, but I can't properly do the shortcut without a home button, and all I have with ddms is a black screen...
Flags: needinfo?(etienne)
Attached video Video of the bug
Better, a video :)
(In reply to Etienne Segonzac (:etienne) from comment #5)
> Created attachment 8366027 [details]
> Video of the bug
> 
> Better, a video :)

Excellent, this really behave the same way as bug 962629. I'm happy, it's not due to PowerVR SGX \o/
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 962629
You need to log in before you can comment on or make changes to this bug.