Search item is broken in customization mode

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ge3k0s, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Firefox 29
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
I noticed a few bugs with the search bar in customization mode.

1. The item has no text in the palette
2. The box is cut on the right
3. The item can't be placed back to the right of the location bar because the other widgets are placed immediately there after the item is dropped.
(Reporter)

Updated

5 years ago
Blocks: 872617
Whiteboard: [Australis:P3]
(Assignee)

Comment 1

5 years ago
At least the cut-off-ness is a regression...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 2

5 years ago
I tried to bisect this using mozregression and got nowhere. :-\
(Assignee)

Comment 3

5 years ago
This was regressed by the flex code I added in bug 922834.
Assignee: nobody → gijskruitbosch+bugs
Blocks: 922834
Status: NEW → ASSIGNED
OS: Windows 7 → All
(Assignee)

Comment 4

5 years ago
Created attachment 8366667 [details] [diff] [review]
search item is broken in Australis' customize code,

So this fixes the styling of the search bar and the bookmarks bar. There's still a separate issue that only occurs if moving the bookmarks toolbar items from the palette to the menu panel, but stops as soon as they've been in the toolbar. Don't think that needs to hold up this bug, though.
Attachment #8366667 - Flags: review?(mdeboer)
Comment on attachment 8366667 [details] [diff] [review]
search item is broken in Australis' customize code,

Review of attachment 8366667 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the following comment addressed:

::: browser/themes/linux/browser.css
@@ +118,5 @@
>  }
>  
> +#wrapper-personal-bookmarks:not([place="toolbar"]) > #personal-bookmarks {
> +  -moz-box-pack: center;
> +}

since you're adding the same block to all platforms' CSS, I'd like you to put this in customizeMode.inc.css
Attachment #8366667 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 6

5 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/849724d4081e

Leaving open for point 3 from comment 0.
Whiteboard: [Australis:P3] → [Australis:P3][leave open]
(Assignee)

Updated

5 years ago
Attachment #8366667 - Flags: checkin+
(Assignee)

Updated

5 years ago
Duplicate of this bug: 966423
(Assignee)

Comment 9

5 years ago
3. is because of the search splitter state, which is getting confused. :-\
(Assignee)

Comment 10

5 years ago
Created attachment 8369346 [details] [diff] [review]
fix search item insertion in Australis customization mode,

So basically, what happens is, customize mode removes the splitter, but then the overflowable toolbar gets disabled, which calls _moveItemsBackToOrigin, which then promptly calls UpdateUrlbarSearchSplitterState, which puts it back again. Let's just teach UpdateUrlbarSearchSplitterState (who picked that function name?) to Not Do That (tm).
Attachment #8369346 - Flags: review?(bmcbride)
Attachment #8369346 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 11

5 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/db60ba91be47
Whiteboard: [Australis:P3][leave open] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/db60ba91be47
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 29

Updated

5 years ago
QA Contact: cornel.ionce
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0


All scenarios mentioned in description are now fixed on latest Firefox Aurora (Build ID: 20140317004002).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.