"helper apps" preferences have no effect

VERIFIED DUPLICATE of bug 93173

Status

SeaMonkey
Preferences
--
major
VERIFIED DUPLICATE of bug 93173
16 years ago
13 years ago

People

(Reporter: kirillov, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for 0.9.4)

(Reporter)

Description

16 years ago
In Preferences/Helper apps I created a MIME type for PDF files, and have
selected "Handle by: application /usr/local/Acrobat4/bin/acroread", and 
"Ask me before opening files of this type". Still, whenever I click on a link to
a PDF file, or enter a URL like 
http://www.math.sunysb.edu/~archive/courses/exams/125/f00/earlyexam/exam.pdf
I get a "Enter name of file to save to..." dialog.

Strange thing is, yesterday Mozilla worked as expected - same version,
everything same. Then, it froze, I killed it, and since after restarting I have
this problem. 

In case you need more details:
I am using Mozilla 0.9.3 on RH Linux 7.1, from RPMS downloaded from mozilla
page. "About" page reports version 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808
And in "helper apps", entry for PDF looks like: 
MIME type: application/pdf
Extension: PDF

Comment 1

16 years ago
I can't even get the default plugin to work on 2001082209/Linux. Doesn't work
with a new profile either.
(Reporter)

Comment 2

16 years ago
If it helps, I can send my mimeTypes.rdf file created by Mozilla. Can't see
what's wrong with it myself. 

Comment 3

16 years ago
Confirming. My experience differs from the reporter's experience in that for me,
absolutely _nothing_ related to helper apps works and it's bugging the heck out
of me.

2001082309/Linux
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: critical for 0.9.4

Comment 4

16 years ago
This is at least severity=major... there might even be a case for calling it a
blocker, since I keep having to run a different browser every time I want to
play a realaudio clip or something similar.
Severity: normal → major
could this be related to bug 96418? or, perhaps, bug 96742?
tried testing this with a build from the night of 8/22...unable to, since i'm
blocked by bug 96418. [namely, no helper dialog comes up at all when i click a
pdf link.]
Depends on: 96418
kirillov, how is this working for you using a recent build?

i'm using 2001.08.29.08-comm bits on linux [rh 6.2, fwiw], and i don't see this
problem. i created a type in the Helper Application pref panel with the same
info as yours [pdf extension, application/pdf mimetype,
/usr/local/Acrobat4/bin/acroread as the app]. when i click on the link you
originally provided, i get the helper app dialog with the "Open with acroread"
radiobutton selected.

i'm marking this as wfm --but pls do reopen if it's still an issue. thx!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

16 years ago
I'll try nightly build tomorrow (if I manage to install it on my system).
Meanwhile, here is a related thing - should I file it as a separate bug, or is
it a known issue (it probably is...):


 In helper apps dialog, I can't just enter command name (acroread) - I need to
enter full path, which is quite inconvenient. Is it really necessary?  Worse, it
wouldn't even accept 
/usr/bin/xdvi - apparently because it is a script; the actual binary name is 
/usr/bin/xdvi.bin - but it took me some time to figure out, and would take most
users forever. Again, can't see any reason why not accept the script...
(Reporter)

Comment 9

16 years ago
Well, I tried the latest build, 2001083008. Things are even worse than before.
In order to have a clean test, I removed ~/.mozilla directory and entered all
prefernces anew. Now:
 *none* of the new file types I enter works: whether I set "save to disk", or
"open using..." in preferences, whenever I click on file of any type other than
html, nothing happens. No dialogs, nothing. It apparenlty loads the file (at
least, the statusbar is filling) and then drops it somewhere. Same for unknown
file types.  

Even if I shift-click on a link, or right-click and select "save as...", still
nothing happens - no dialogs, no nothing. Annoying to say the least.

 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
kirillov, there's indeed horkage today --perhaps bug 93173 and/or bug 97658 are
getting in the way of testing this one!

also, re: your fullpath question: could you search bugzilla to see if it already
exists? if not, go ahead a file one. i don't know if it's "expected" behavior...

Comment 11

16 years ago
That would be bug 56662
kirillov, i'm thinking this is prolly a dup of bug 93173...

*** This bug has been marked as a duplicate of 93173 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
*** Bug 96620 has been marked as a duplicate of this bug. ***
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.