bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Pressing the bookmark menu button also depresses the bookmark star icon

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: phlsa, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 30
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3+])

Attachments

(1 attachment)

On Mac, if you click and hold the bookmarks menu button, you'll see that the bookmark star icon also shows its depressed state. Those buttons should work independently of each other in that respect (as they already do on Windows)
I thought there was a bug on file for this already but I can't find it.
Blocks: 872617
Whiteboard: [Australis:P?] → [Australis:P3][DUPEME]
Version: 28 Branch → Trunk
Whiteboard: [Australis:P3][DUPEME] → [Australis:P3+][DUPEME]
(Assignee)

Comment 2

5 years ago
What about the blue star? Should that show if you have the panel open? On Windows, the left side also doesn't change state, so I would assume not... but your comment #0 didn't specify this.
Flags: needinfo?(philipp)
(Assignee)

Comment 3

5 years ago
Created attachment 8373722 [details] [diff] [review]
fix star button pressed state on Australis,

This also adjusts the star. Leaving out the deletions of the [open] hunks would fix only the pressed state, without affecting the blue star showing.
Attachment #8373722 - Flags: review?(mdeboer)
(Assignee)

Updated

5 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
I agree, the blue star should not show up when the panel opens – just as on Windows.
Flags: needinfo?(philipp)
Comment on attachment 8373722 [details] [diff] [review]
fix star button pressed state on Australis,

Review of attachment 8373722 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the side-note that I don't see any use for the blue arrow at all anymore, am I right? If so, we better remove it from Toolbar.png altogether.
Attachment #8373722 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 6

5 years ago
(In reply to Mike de Boer [:mikedeboer] from comment #5)
> Comment on attachment 8373722 [details] [diff] [review]
> fix star button pressed state on Australis,
> 
> Review of attachment 8373722 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me with the side-note that I don't see any use for the blue arrow at all
> anymore, am I right? If so, we better remove it from Toolbar.png altogether.

(I'm guessing you mean blue star)

Yes, but that can be a low-prio followup.

There's something to be said for using it when the 'edit bookmark' panel drops down from the star. Unfortunately, we already use a yellow star in that case (because the page is bookmarked) and so overriding that with the blue star would be a little weird... in any case, for now this will fix things up to be non-super-weird, and we can decide on what 'perfect' means in this area in another bug, which I will file in a sec. :-)

remote:   https://hg.mozilla.org/integration/fx-team/rev/690e76bd7d90
Whiteboard: [Australis:P3+][DUPEME] → [Australis:P3+][fixed-on-fx-team]
(Assignee)

Updated

5 years ago
Depends on: 970857
https://hg.mozilla.org/mozilla-central/rev/690e76bd7d90
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
(Assignee)

Comment 8

5 years ago
Comment on attachment 8373722 [details] [diff] [review]
fix star button pressed state on Australis,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: OS X star icon looks odd when clicking its menu button part
Testing completed (on m-c, etc.): m-c, locally
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8373722 - Flags: approval-mozilla-aurora?
Attachment #8373722 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
status-firefox30: --- → fixed
Whiteboard: [Australis:P3+][fixed-on-fx-team] → [Australis:P3+]

Updated

4 years ago
QA Contact: cornel.ionce
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0

Verified fixed on latest Aurora (build ID: 20140324004000) and on Firefox 29 beta 1(build ID: 20140318013849).
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.