Can not align table using the toolbar buttons after the aignment was changed in table properties

VERIFIED DUPLICATE of bug 54912

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 54912
17 years ago
14 years ago

People

(Reporter: TucsonTester2, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)
BuildID:    20010816

After changing the table's alignment using the table properties menu I was not 
able to change the alignment using the toolbar.  Only the default left alignment 
worked properly so that I could align using the toolbar.

Reproducible: Always
Steps to Reproduce:
1.Open Composer
2.Create a 2x2 table with a 100 pixel width
3.double click the table to bring up table properties
4.click on the table tab and choose right or center in the table alignment box 
and click ok
5.Control click the center of the table to highlight the entire table
6.Click on one of the alignment options available in the toolbar

Actual Results:  The table did not align properly when trying to edit the 
table's alignment using this method.  While the table was center aligned I did 
notice that the table moved slightly for each alignment I choose.  With the 
right alignment chosen in table properties I did not notice any movement while 
using the toolbar.  The alignment does not change using the format menu either.

Expected Results:  The alignment chosen in the table properties window should be 
overwritten by the what alignment I choose fromt the toolbar or the format menu.

Here is an example of a table I tried to right align while it was centered by 
table properties.  The buttons on the toolbar added in the <div> tag to adjust 
the table while the table properties added the align="center" to the <table> 
tag.  Should the software know that I'm editing a table since the whole table is 
selected by the control click?

<div align="Right">
<table cellpadding="2" cellspacing="2" border="1" width="100" align="Center">
  <tbody>
    <tr>
      <td valign="Top"><br>
      </td>
      <td valign="Top"><br>
      </td>
    </tr>
    <tr>
      <td valign="Top"><br>
      </td>
      <td valign="Top"><br>
      </td>
    </tr>
  </tbody>
</table>
</div>
(Reporter)

Comment 1

17 years ago
I just also recently seen this happen with horizontal rules as well as images.  
It appears anything that has it's own property window and has an alignment 
option is effected by this.  Shouldn't the software know if I have one of these 
objects selected that it needs to be changed in the tag ( <img>, <hr>, etc.), 
instead of adding a <div> tag to adjust the alignment?

Comment 2

17 years ago
-->charley

Daniel--does your css work affect this bug?
Assignee: brade → cmanske
(Assignee)

Comment 3

17 years ago
Nope, current code is not smart enough to look for existing "align" attribute.
This should be fixed in HTML rules code (right Joe?), but I'll take a look at
how hard that would be to do.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Can not align table using the toolbar buttons after the alignment was changed in table properties → Can not align table using the toolbar buttons after the aignment was changed in table properties
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.6

Comment 4

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 54912 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.