If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

--disable-webm builds are broken. (--disable-webm needs to be removed)

RESOLVED DUPLICATE of bug 1232223

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1232223
4 years ago
2 years ago

People

(Reporter: dholbert, Assigned: bechen)

Tracking

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Bug 891705 seems to have broken --disable-webm builds. Before its cset landed, I could build; now I cannot (unless I install libvpx-dev, which rillian says I shouldn't have to do).

In particular, I get this build failure:
{
media/libmkv/EbmlWriter.h:18:10: fatal error: 'vpx/vpx_integer.h' file not found
#include "vpx/vpx_integer.h"
          ^
}

I think this is just related to --disable-webm, but FWIW, here's my mozconfig:
{
ac_add_options --enable-debug --disable-optimize
ac_add_options --disable-crashreporter
ac_add_options --disable-installer
ac_add_options --disable-updater
ac_add_options --enable-valgrind
ac_add_options --enable-warnings-as-errors
ac_add_options --enable-profiling
ac_add_options --disable-accessibility
ac_add_options --disable-gamepad
ac_add_options --disable-gstreamer
ac_add_options --disable-jsd
ac_add_options --disable-ogg
ac_add_options --disable-opus
ac_add_options --disable-universalchardet
ac_add_options --disable-necko-wifi
ac_add_options --disable-wave
ac_add_options --disable-webapp-runtime
ac_add_options --disable-webgl
ac_add_options --disable-webm
ac_add_options --disable-webrtc
ac_add_options --disable-webspeech
ac_add_options --without-intl-api
}
(Reporter)

Updated

4 years ago
Summary: Bug 891705 seems to have broken --disable-webm builds → Bug 891705 seems to have broken --disable-webm builds, with "media/libmkv/EbmlWriter.h:18:10: fatal error: 'vpx/vpx_integer.h' file not found"
Ok, --disable-webm probably prevents the libvpx header export. We should either make the encoder conditional on MOZ_WEBM or remove the switch altogether. I propose the later.
(Reporter)

Comment 2

4 years ago
(See also bug 964488, BTW.)
Assignee: nobody → rlin
Hi Bengamin, 
Please help this, thanks a lot.
Assignee: rlin → bechen
(Reporter)

Comment 4

4 years ago
Note that rillian has suggested getting rid of some of these "--disable-codec" options entirely (e.g. bug 964559), which would make this a non-issue.

(Not sure if "--disable-webm" is on the chopping block or not; CC'ing him so he can chime in.)
(Reporter)

Comment 5

4 years ago
[er, right, he suggested removing --disable-webm here, in comment 1. Sorry, didn't scroll back far enough.]

Comment 6

3 years ago
(In reply to Ralph Giles (:rillian) from comment #1)
> Ok, --disable-webm probably prevents the libvpx header export. We should
> either make the encoder conditional on MOZ_WEBM or remove the switch
> altogether. I propose the later.

What exactly would removing --disable-webm mean? That it would always be built? What would happen when yasm is not present?
Yes, webm support would always be compiled in, and yasm would be required for the build.
(Reporter)

Comment 8

3 years ago
FWIW, --disable-webm still exists as a config option, though now the first bustage I hit with that in my mozconfig is:
{
dom/media/mediasource/ContainerParser.cpp:9:10: fatal error: 'WebMBufferedParser.h' file not found
}
(Reporter)

Updated

3 years ago
Summary: Bug 891705 seems to have broken --disable-webm builds, with "media/libmkv/EbmlWriter.h:18:10: fatal error: 'vpx/vpx_integer.h' file not found" → --disable-webm builds are broken. (--disable-webm needs to be removed)
Component: Audio/Video → Audio/Video: Playback
Depends on: 1232223
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232223
You need to log in before you can comment on or make changes to this bug.