Closed Bug 964485 Opened 6 years ago Closed 6 years ago

Calling `HomeStorage.deleteAll()` on a non-existing table throws error

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 965460

People

(Reporter: mcomella, Unassigned)

References

(Blocks 1 open bug)

Details

This occurs if `HomeStorage.save()` has not yet been called (as it creates the table in the DB).

The error output is not very helpful: "Error: Error(s) encountered during statement execution".

Don't forget to add a test case! ^_^ See bug 963352.
Thanks for filing! I added a comment, but didn't get around to filing a bug:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/modules/HomeProvider.jsm#106
Blocks: lists
Fixed by bug 965460.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965460
You need to log in before you can comment on or make changes to this bug.