[B2G][Card View] User can quickly re-enter a cached app after killing said app from card view.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: pfield, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dogfood1.3)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8366323 [details]
Cachedapp.mp4

Description: 
The user is able to enter an app that has been closed. The app functions as intended until the user tries to go to the home screen, and then if the user tries to view the app running in the card view from this point, no apps will be running.

1) Updated Buri to Build ID: 20140127004002
2) Open an app. (Does not matter which, for this bug I used the dialer app.)
3) Type some numbers into the dialer app. (example 123456) 
4) Open card view.
5) Quickly tap on the suspended app while trying to swipe to kill the app.
6) When the home screen appears, quickly tap the dialer app.
7) If step 6 fails and there are no signs of a cached app, repeat steps 2-6.
8) If step 6 succeeds tap the home button to return home.
9) Long press the home button and enter card view.

Actual:
No apps will be running, even though the dialer app would be suspended, since it was just exited.

Expected:
The phone brings a user to a freshly opened dialer app and does not save any previous data.

Environmental Variables
Device: Buri v 1.3.0 Mozilla
Build ID: 20140127004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/c40099a42c1f
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 3/8  

See attached: Video - Logcat

Optional extra notes: 

-This issue seems to be best noticeable on apps that allow user input, such as the dialer app or the messaging app.
(Reporter)

Comment 1

4 years ago
Created attachment 8366325 [details]
logofcachedapp.txt

Could not get to repro in Buri V 1.2

Environmental Variables:
Device: buri 1.2 COM
BuildID: 20140127004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: d10e1f965d0c
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: v1.2-device.cfg
While this is a regression, the impact is minor & it's an edge case.
Keywords: regression

Comment 3

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.