Apprunner thinks window is always 640x480 pixels

VERIFIED WORKSFORME

Status

()

P2
normal
VERIFIED WORKSFORME
20 years ago
20 years ago

People

(Reporter: kherron+mozilla, Assigned: danm.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
First observed 7/11/99. When run, apprunner's initial window is 640x480.
Window can be resized, but contents aren't redrawn. Click on a link or hit
reload and the page, scroll bars, menus, & all other widgets are redrawn as if
window were 640x480 regardless of window's actual size.

If window is resized smaller than 640x480, then the page, scrollbars, etc. are
clipped at the window boundary as expected.  Resize the window larger and the
stuff reappears.  Size the window larger than 640x480 and you'll get neutral
gray in the unused portions.

Updated

20 years ago
Assignee: trudelle → danm
Priority: P3 → P2
Target Milestone: M8

Comment 1

20 years ago
reassigning to danm as p2 for m8, since it sounds like a regression that
prevents using as dogfood. cc mcafee
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

20 years ago
I remember seeing that problem, too, on the 9th, I think. However, my current build was pulled
in the late afternoon of the 11th, and doesn't have the problem.  Whoever broke it must have
noticed and done something about it. Redrawing is awful to watch: you can see its gears grinding
from start to finish, but none of the problems mentioned in this bug are still present..
(Assignee)

Comment 3

20 years ago
(NB: windows refuse to be sized under 640x480 in my current build.)
(Reporter)

Comment 4

20 years ago
A source update and rebuild later, and the problem has disappeared for me as
well.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
marking verified due to reporter's comments.
You need to log in before you can comment on or make changes to this bug.