[Devices][MTP][Gaia] Add USB Storage panel with MTP/UMS selection

RESOLVED FIXED in 2.1 S3 (29aug)

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: iliu@mozilla.com, ianliu.moz@gmail.com, Assigned: gasolin)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.1)

Details

(Whiteboard: [ft:devices][p=5])

Attachments

(2 attachments)

According to the user story in Bug 922927, we have to implement following items for reaching the user story.

1. If USB storage is disabled, grey out "Share using USB" toggle button.(This is an improving item for interaction.)
2. Remove "USB storage toggle button" from  Settings::Media storage.
3. Let the MTP is always enabled.(Gaia is able to control the flag while platform is ready to support.)
For the item 3, it will need MTP supporting via platform. Then, it's able to toggle MTP enabled/disabled via settings key.
(Reporter)

Updated

4 years ago
Depends on: 748350

Updated

4 years ago
feature-b2g: --- → 2.1

Updated

3 years ago
Assignee: nobody → iliu
Whiteboard: [ft:Devices]

Updated

3 years ago
Whiteboard: [ft:Devices] → [ft:devices]

Updated

3 years ago
Target Milestone: --- → 2.1 S3 (29aug)

Updated

3 years ago
Summary: [Devices][Gaia] Media Transfer Protocol → [Devices][MTP][Gaia] Media Transfer Protocol

Updated

3 years ago
Duplicate of this bug: 1052885

Updated

3 years ago
Component: General → Gaia::Settings
No longer depends on: 748350
(Assignee)

Comment 3

3 years ago
In transfer protocol page, will set

ums.mode : 1 -> UMS
ums.mode : 3 -> MTP

based on bug 1043264 comment 6
(Assignee)

Comment 4

3 years ago
Ian will handle origin media storage related change in bug 943825. I'd help make new usb_storage panel

The new spec is:

1. add new link left of USB storage switch
2. add a protocol selection panel contains (mtp / ums) (set mtp by default)
3. change mode based on protocol selection result
Assignee: iliu → gasolin
Summary: [Devices][MTP][Gaia] Media Transfer Protocol → [Devices][MTP][Gaia] Add USB Storage panel with MTP/UMS selection
(Assignee)

Comment 5

3 years ago
Created attachment 8475742 [details] [review]
pull request redirect to github

WIP for gecko test, need refactor and unit test
I would have thought that UMS should be set by default, since that's what we've been using in the past.

Making MTP be the default seems a bit premature right now, especially since its new, and we know it doesn't work anywhere near as reliably as UMS.
(Assignee)

Comment 7

3 years ago
ni jenny(UX) to clarify Dave's comment 6 about why set MTP by default.

From tech perspective, ni alphan, if Dave and you feel UMS is better fit for current release, we should do that and fire followup bug to change default to MTP for future release.
Flags: needinfo?(jelee)
Flags: needinfo?(alchen)
In my opinion, if there is UMS support, it is good to set UMS as default.
UMS is more stable and faster than MTP.
As Dave said, UMS can work well on anywhere but MTP can't.
Flags: needinfo?(alchen)

Comment 9

3 years ago
If there's technical concerns, I'm ok with using UMS as default. However, when MTP is stabilized in the future, we should switch back to MTP. Thank you!
Flags: needinfo?(jelee)
(Assignee)

Comment 10

3 years ago
Comment on attachment 8475742 [details] [review]
pull request redirect to github

set feedback flag to get some feedback before unit tests are done.
Attachment #8475742 - Flags: feedback?(ejchen)
Comment on attachment 8475742 [details] [review]
pull request redirect to github

F+ for settings part. Please check my comments on Github ! Thanks ;)
Attachment #8475742 - Flags: feedback?(ejchen) → feedback+
(Assignee)

Comment 12

3 years ago
Comment on attachment 8475742 [details] [review]
pull request redirect to github

Thanks EJ for feedback. Unit test added. Set review for system part.

will set settings review after add the split menu UI.
Attachment #8475742 - Flags: review?(alive)
(Assignee)

Comment 13

3 years ago
Comment on attachment 8475742 [details] [review]
pull request redirect to github

split menu added, @ej please help review it. Thanks!
Attachment #8475742 - Flags: review?(ejchen)
(Assignee)

Comment 14

3 years ago
Created attachment 8478152 [details]
screenshot

set UI review
Attachment #8478152 - Flags: ui-review?(hhuang)
Comment on attachment 8478152 [details]
screenshot

Hi Fred, it looks good! Thank you!
Attachment #8478152 - Flags: ui-review?(hhuang) → ui-review+
Comment on attachment 8475742 [details] [review]
pull request redirect to github

r+ with nits
Attachment #8475742 - Flags: review?(alive) → review+
Comment on attachment 8475742 [details] [review]
pull request redirect to github

Thanks Fred, r+ with nits on Github.

:)
Attachment #8475742 - Flags: review?(ejchen) → review+
(Assignee)

Comment 18

3 years ago
Thanks for review. I've addressed your comments, will fix TBPL test issue before land.
(Assignee)

Updated

3 years ago
Whiteboard: [ft:devices] → [ft:devices][p=5]

Comment 19

3 years ago
Confirmed with EM/EPM, and this can be landed before FL.
(Assignee)

Comment 20

3 years ago
merged https://github.com/mozilla-b2g/gaia/commit/abaa255760cf075c822ca8858cc556dc001906dc

thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Depends on: 1059135
(Assignee)

Updated

3 years ago
Blocks: 1061090

Updated

3 years ago
Depends on: 1070137
Depends on: 1073433
Depends on: 1169821
You need to log in before you can comment on or make changes to this bug.