Closed Bug 964631 Opened 6 years ago Closed 4 years ago

Empty string passed to getElementById().

Categories

(DevTools :: Console, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 45

People

(Reporter: indersi1, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131202182626

Steps to reproduce:

its kind of auto complete when i type the error occur  in console Empty string passed to getElementById().


Actual results:

Empty string passed to getElementById(). error occur  


Expected results:

auto-completed data must be auto populated
Severity: normal → major
Component: Developer Pages → Developer Tools
Product: Marketplace → Firefox
Version: 2.0 → unspecified
I'm not sure I follow. What is the exact thing that you type in the web console, what is the resulting output and what did you expect to see instead?
Component: Developer Tools → Developer Tools: Console
Flags: needinfo?(indersi1)
Tested on:
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0

Steps to reproduce:
1. load any page in tab
2. show console (ctrl+shift+k)
3. type without quotation '[1].'
4. press tab key
5. [FAIL] "Empty string passed to getElementById()." message appears in console, pointing to resource://gre/modules/devtools/DevToolsUtils.js line 215

Expected result:
'<- no result' or completion list should appear

Notes:
* '1' in step 3 can be substituted by any non-negative integer in standard form (it works ok for negative number, fractional numbers,hex number, expressions other then number literals)
* it works ok on 'about:newtab', 'about:config', the bug appears on 'about:blank' or websites
I can reproduce that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(indersi1)
There are a number of such bugs about this warning 'empty string...'. Even putting try-catch around the code that iterates the document properties doesn't help.

We should probably get rid of the warning entirely.
Depends on: 1216668
This appears to be fixed by Bug 1216668
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
(In reply to Brian Grinstead [:bgrins] from comment #5)
> This appears to be fixed by Bug 1216668

Sorry, but it still seems to be prevalent: Firefox 47 still getting this.
Firefox: 47
jquery: 2.1.3
one dropdown list in the code
(In reply to Jobst Schmalenbach from comment #6)
> (In reply to Brian Grinstead [:bgrins] from comment #5)
> > This appears to be fixed by Bug 1216668
> 
> Sorry, but it still seems to be prevalent: Firefox 47 still getting this.
> Firefox: 47
> jquery: 2.1.3
> one dropdown list in the code

This error was being triggered by the console itself.  If a page causes the error I'm thinking it should still show up - but to be sure can you paste the full error (with stack) and/or link to a page that causes the error?
Duplicate of this bug: 624311
Product: Firefox → DevTools
Duplicate of this bug: 1524216
You need to log in before you can comment on or make changes to this bug.