nsComponentManager::nsFactoryEntry Eliminate strings type (for enum) and location

RESOLVED DUPLICATE of bug 96701

Status

()

Core
XPCOM
P3
normal
RESOLVED DUPLICATE of bug 96701
17 years ago
17 years ago

People

(Reporter: Suresh Duddi (gone), Assigned: Suresh Duddi (gone))

Tracking

({perf})

Trunk
mozilla0.9.5
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
We create about 700 nsFactoryEntries. With an average lenght of 16 bytes per
location entry and 32 bytes for the native component type, this amounts to

- 1400 allocations
- 33k of space : 700*(16+32)
- 1400 string copies
(Assignee)

Updated

17 years ago
Blocks: 7251
Status: NEW → ASSIGNED
Keywords: perf
Target Milestone: --- → mozilla0.9.5
(Assignee)

Updated

17 years ago
Priority: -- → P3
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 96701 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.