[Sora][video player]it would not stop playing instantly after press home key

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Mozilla build ID: 20140118004001
 
 DEFECT DESCRIPTION:
 Video would not stop playing instantly.
 
  REPRODUCING PROCEDURES:
 1.Launch video player;
 2.Select one video to play;
 3.Press delete icon and then press home key during playing;
 
  EXPECTED BEHAVIOUR:
 It can stop playing instantly.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:5/5
Does this reproduce on a 1.1 Buri device?
Flags: needinfo?(sync-1)
Can reproduce this one on Buri 1.1 as well. Also please note that when back to home screen, you cannot see the video but just heard the video sounds
Flags: needinfo?(sync-1)
One question for sync-1: does the video pause playing after 3 seconds of pressing home button?

We have a mechanism to defer the visibility change event for 3 seconds. In video app, we pause it when we receive the visibility change event.
Flags: needinfo?(sync-1)
Hi John -

I just made a video of this issue, please check it at http://www.youtube.com/watch?v=5W1lp2oa0Gw&feature=youtu.be

In fact, the issue is that during the video playback, if user press "home" key, the video will stop play immediately and the handset will back to idle screen, however, in the idle screen you can still hear the sound of the video for like 2 seconds.

Could you help to check if that is a normal behavior or not?

Thanks

Vance
Flags: needinfo?(sync-1) → needinfo?(johu)
Ok, this is a normal behavior. But it's a known "issue" I think. I cannot remember the bug number. But alive may know the exact dependency about why and why not it is this behavior.
Flags: needinfo?(johu)

Comment 6

5 years ago
Hi John, 

I don't mean to offend any one.

From viewpoint of end user, despite of whatever reason for current behavior,  sound of video must stop instantly when video player switched to background.
  
Jack
NI Alive.

Hi Alive, could you kindly help to explain why we have this problem?I am thinking maybe it is a software/hardware limitation such that for some reason the music just cannot stop immediately, but will keep play for two seconds?
Flags: needinfo?(alive)
The video stops playing once the page visibility is changed to background,
but if we do sending video app to background immediately after home button is pressed you will see a "white" video app when you closes it.

This issue could be resolved when we move the audio channel service from gecko to gaia
http://bugzil.la/app-audio-channel but for now we are still far away. expect 1.5 targeted.
Flags: needinfo?(alive)

Comment 9

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.