[Regression] Template Editor: Ace is not initializing

RESOLVED FIXED

Status

developer.mozilla.org
Editing
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: fscholz, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

4 years ago
What did you do?
================
Edit a template.

What happened?
==============
Ace editor is not there.

What should have happened?
==========================
Ace editor should be initialized allowing better editing of Kumascript macros.

Is there anything else we should know?
======================================
We had the same regression in the past in bug 787973.
Can we add a test to catch this?
(Reporter)

Updated

4 years ago
Severity: normal → major
Component: General → Editing
Looking at this now...
Fix here, on the way:  https://github.com/mozilla/kuma/pull/1927

I'll look at client side testing within the coming weeks.
(Reporter)

Comment 3

4 years ago
Thanks for being so quick here! DW FTW!

Comment 4

4 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/e4c791649efc5cd2ce884d62e54d8e74ea47cd70
fix bug 964664 - Remove ace editor bundle, move scripts to own resource

more

https://github.com/mozilla/kuma/commit/f6ec85b833326241708841ffc01d4c5246168a73
Merge pull request #1927 from darkwing/ace-initializer

fix bug 964664 - Remove ace editor bundle, move scripts to own resource

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.