Firefox stops responding when visiting <http://www.style36.co.za/>

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
5 years ago
4 years ago

People

(Reporter: jonathan, Unassigned)

Tracking

({hang})

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140203])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140127004003

Steps to reproduce:

1. Visit <http://www.style36.co.za/>. (I tried safe mode too.)



Actual results:

At some point in the page load (the page loads at least partially) the browser stops responding entirely.


Expected results:

The page should have loaded and the browser should have continued functioning.

The frustrating part about this is that there is no obvious way for a mortal to inspect the state of the browser at this point, the entire application is unresponsive (using 100% of a CPU core). Since the browser doesn't actually crash, no crash report is submitted or generated. So what's left is for someone to file a legitimate bug that says "It's not working" but nobody else can reproduce or extract the necessary information from.

It seems likely (based on previous experience of similar issues) that restarting the computer will seemingly cause this problem to go away, and though that might seem like a hardware issue there are no other problems with any other software on the same computer (try as I might.)
(Reporter)

Updated

5 years ago
OS: Mac OS X → Windows 7
Hardware: x86 → x86_64
(Reporter)

Updated

5 years ago
Hardware: x86_64 → x86
(Reporter)

Comment 1

5 years ago
(I'm reporting this bug from another computer, the problem occurred on a Windows 7 (64-bit) machine running Firefox Nightly 2014-01-27.)

Comment 2

5 years ago
Created attachment 8369526 [details]
5 Errors in the Dev Consol.png

Comment 3

5 years ago
[bugday-20140203]

Tested on FF Nightly 29.0a1 (2014-02-03) Windows 7 32 bit

I get the page correctly loaded quickly and once loaded it does have an automatic carousel, which I watch run for 10 minutes, with nothing that looked like an issue.

I did see one interesting thing the Developer tools almost immediately set a red box in the bottom right corner with a 5

I am attaching a screen shot showing the syntax Errors:

SyntaxError: Using //@ to indicate sourceMappingURL pragmas is deprecated. Use //# instead jquery-1.10.2.min.js:1
Error: http://static.style36.co.za/catalog/view/theme/bootstrap/libs/jquery-1.10.2.min.js?v=rel1391177276426037607 is being assigned a //# sourceMappingURL, but already has one
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. jquery-1.10.2.min.js:5
SyntaxError: illegal character dc.js:1
SyntaxError: illegal character roundtrip.js:1
SyntaxError: illegal character seg:1
SyntaxError: illegal character seg:1
SyntaxError: illegal character db7a7498da:1
GET http://484-events.olark.com/nrpc/p [HTTP/1.1 200 OK 73ms] 

Does the bug happen in competing browsers?

Does the bug happen on other Firefox versions?

Do any other sites have the same issue?

Comment 4

5 years ago
WFM with
2014-01-27-03-02-01-mozilla-central-firefox-29.0a1.en-US.linux-x86_64
2014-01-27-07-20-47-mozilla-central-firefox-29.0a1.en-US.linux-x86_64
2014-02-03-03-02-03-mozilla-central-firefox-29.0a1.en-US.linux-x86_64

Updated

5 years ago
Severity: normal → critical
Keywords: hang
Whiteboard: [bugday-20140203]
(Reporter)

Comment 5

5 years ago
Not that I would have been able to open the developer tools, but that is interesting.

It doesn't happen in any other browser I tested, it didn't happen in Firefox Aurora on an OS X machine. I couldn't find any other particularly troublesome site but I'll admit to not trying very hard. As I suspected, and noted in my original comment, that restarting the system caused this issue to vanish.

This kind of thing is an incredibly frustrating experience, apart from my entire browser locking up, there is almost nothing I can do to accurately report the issue; there are no logs or crash dumps I am aware of.

Comment 6

5 years ago
Hey Jonathan,

We are definitely working on this, but please note not to change the priority of the bug, it is for the developers. Also, I don't think the description qualifies critical. 
For your reference: https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity 

Have you tried checking up the same with the latest version of the browser. Also, I see that the site right now is closed. What do you think?
(Reporter)

Comment 7

5 years ago
I didn't change the priority of the bug, as the history clearly indicates.

I'm using Firefox Nightly on a daily basis, this problem was not specific to this one site, it just happened to be the one I could reproduce it on at the time. As I mentioned in my previous comments, restarting the computer caused this issue to disappear. MAGIC!

Since there was no crash report and no tool that would have enabled me to actually determine why this problem was happening at the time, I have no idea what caused this, so I don't know what I'm supposed to think. Maybe it'll happen again and I'll be unable to determine if it's the same problem as last time?

I was encouraged by #firefox to report the bug, against my better judgement. My main point of contention here is that this is the kind of bug that is incredibly frustrating to deal with and yet will never be reported to Mozilla in a highly technical way that might help find the root cause.

Comment 8

5 years ago
Thanks Jonathan!

Team, looks like the problem is resolved. In that case, might we proceed resolving?
(Reporter)

Comment 9

5 years ago
This feels like some kind of nightmare, to be honest; words are coming out but nobody can understand them.

What, pray tell, was the problem? I sure don't know what the problem is, nobody else writing on this ticket does either apparently, so how exactly does one resolve an unknown issue? I guess there's no SWEPTUNDERTHERUG bug status.

Comment 10

5 years ago
I understand Jonathan, but you had been working on Nightly. I checked it with Firefox 27.0.1 and it seems working good. Did I go somewhere, wrong?
(Reporter)

Comment 11

5 years ago
No probably not. If it happens again I'll file another bug. Thanks.

Comment 12

5 years ago
Unfortunately, I can't reproduce this.

Jonathan, if you can still reproduce this issue at some point, please update this report with more details about that. There is no need to file another bug since this report is already here.

Sujith, Nightly is an upcoming version (a Firefox version that will be released in the future), so if a bug reproduces on it, the bug should stay open until fixed. This is also valid for Beta and Aurora.
Component: Untriaged → General
http://www.style36.co.za/ is still gone so this isn't bug actionable.

Jonathan, thanks for your report and please file a new bug if you see something like this again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.