thunderbird-24.2.0: hangs-up on preview mail, contains very long string

RESOLVED DUPLICATE of bug 736951

Status

RESOLVED DUPLICATE of bug 736951
5 years ago
4 years ago

People

(Reporter: Ikonta, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20140113121555

Steps to reproduce:

I've received a mail.
As post-analyse showed, containing very long text string (above 6 megabytes).

Is it enough, or I should attach issued.eml?


Actual results:

On selection this mail in list, normally executed mail preview failed, and Tunderbird's window falls into non-response state (finally killed by DE).


Expected results:

I expect the mail to be shown, or to see any human-readable error message.
Without application hang-up.

Comment 1

5 years ago
Created attachment 8366575 [details]
4kln.png

Hi, It working fine.
Could you check in safe mode.

Check my attachment.
(Reporter)

Comment 2

5 years ago
(In reply to iamjayakumars from comment #1)
> Hi, It working fine.
> Could you check in safe mode.
> 
> Check my attachment.

The same issue with thunderbird started with '-safe-mode' option.

Are you shure, that you've correctly reproduced my issue?
I got ot not only with ordinar plain text email, but with _single string_ (unix string!) text email (all 6+ megabytes were written to the single string, e-mail contains with the only this string).

P.S. Another possiblely important detail: I use Gentoo built binary.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736951

Updated

4 years ago
Component: Untriaged → Message Reader UI

Comment 4

4 years ago
I confirm this bug happen with xml attachments (e.g. 1 MB) and Thunderbird is near to hang.
I it blocking the GUI.
You need to log in before you can comment on or make changes to this bug.