focused <select size=1> picklist intercepts ^F4

RESOLVED FIXED in mozilla29

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: lvm, Assigned: mats)

Tracking

Trunk
mozilla29
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first verify])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23 (Beta/Release)
Build ID: 20131210201652

Steps to reproduce:

* open any tab
* open a document with <select size=1> picklist (e.g. this bug submission page https://bugzilla.mozilla.org/enter_bug.cgi#h=bugForm|SeaMonkey) in a second tab
* click on the picklist to focus it (e.g. Version picklist)
* press ^F4


Actual results:

pressing ^F4 toggles picklist open state


Expected results:

tab shoud've closed

Updated

4 years ago
Component: General → Layout: Form Controls
OS: Windows XP → All
Product: SeaMonkey → Core
Hardware: x86 → All
Version: SeaMonkey 2.23 Branch → Trunk
(Assignee)

Comment 1

4 years ago
I don't know what you mean by "press ^F4".  Is that Shift+F4 or Ctrl+F4
or just a plain F4? (or something else)
(Reporter)

Comment 2

4 years ago
ctrl-f4 - the command which is supposed to close a tab. http://en.wikipedia.org/wiki/Control_key#Notation
(Assignee)

Comment 3

4 years ago
Created attachment 8367238 [details] [diff] [review]
fix

My local Windows build is broken beyond repair (bug 964930),
so I haven't tested this at all.
https://tbpl.mozilla.org/?tree=Try&rev=54ef5626db58
Assignee: nobody → matspal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8367238 - Flags: review?(bzbarsky)
Comment on attachment 8367238 [details] [diff] [review]
fix

Seems plausible.
Attachment #8367238 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 5

4 years ago
I tested the Try build - it worked as intended.
https://hg.mozilla.org/integration/mozilla-inbound/rev/9024723e97d3
Severity: normal → minor
OS: All → Windows XP
https://hg.mozilla.org/mozilla-central/rev/9024723e97d3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Updated

4 years ago
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.