(Synth APK) - Launching a privileged packaged app does not work

VERIFIED FIXED in Firefox 30

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

29 Branch
Firefox 30
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox29 affected)

Details

(URL)

(Reporter)

Description

5 years ago
Currently launching a privileged packaged app does not work successfully. On launch, all I see the splash icon (an Android icon) and nothing happens.

Visit http://mozqa.com/webapi-permissions-tests/ and click install on 'Packaged App' (Packaged App Test Case 1) on launch

{
  "name" : "New Privileged App",
  "version" : "1.1",
  "size" : 16000,
  "release_notes": "First v1.1 release",
  "icons": {
    "126": "/webapi-permissions-tests/qalogo.png"
  },
  "developer": {
    "name": "Mozilla QA",
    "url": "http://jasondanielsmith.wordpress.com/"
  },
  "package_path": "/webapi-permissions-tests/privilegedappnosigning.zip"
}

Which has a package path and a zip which contains a .webapp with: 

{
  "version": "1.1",
  "name": "New Privileged App",
  "description": "A different privileged app",
  "launch_path": "/privilegedapp.html",
  "icons": {
    "128": "/qalogo.png"
  },
  "type": "privileged",
  "permissions": {
    "device-storage:pictures": {
      "access": "readwrite",
      "description": "Come see my device storage"
    },
    "contacts": {
      "access": "readwrite",
      "description": "Come see my contacts"
    }
  },
  "developer": {
    "name": "Mozilla QA",
    "url": "http://jasondanielsmith.wordpress.com/"
  }
}

Side-Note: This should not be using the Android icon as the default icon for the application; I would have expected the APK factory can pluck out any icons from the packaged path.
(Reporter)

Updated

5 years ago
status-firefox29: --- → affected
I can reproduce, and logcat shows:

 29794           GeckoConsole  E  [JavaScript Error: "Error installing app from: http://mozqa.com: INVALID_SECURITY_LEVEL" {file: "resource://gre/modules/Webapps.jsm" line: 1844}]

Which should be line 20267 <https://github.com/mozilla/gecko-dev/blob/01c2a7f8579d63b8a9985478a56833f02a1c41cd/dom/apps/src/Webapps.jsm#L2067>.  Which is in doInstall, so it looks like the app is being installed via doInstall, whereas it should be installed via doInstallPackage, since it's a packaged app.
aaronmt: based on comment 1, I think this was a problem in mozqa.com rather than Fennec.  It also looks like the issue has been addressed.  So I'm resolving this bug.  But please reopen it if you can still reproduce the problem (and feel free to move it to a more appropriate product/component).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.