Closed Bug 964930 Opened 10 years ago Closed 10 years ago

LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt

Categories

(Firefox Build System :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: MatsPalmgren_bugz, Unassigned)

Details

Attachments

(1 file)

Attached file Full build log
This is probably some problem in my Windows installation, but
I can't figure out what the problem is, so I would appreciate
some help.  It's a default Firefox build, it fails with:

 4:42.97 crashinject.exe
 4:43.08 Executing: link -NOLOGO -OUT:crashinject.exe -PDB:crashinject.pdb -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH -DEBUG -DEBUGTYPE:CV -DEBUG -OPT:REF @e:\src\inbound\obj-i686-pc-mingw32\build\win32\tmphzfo2c.list module.res kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib
 4:43.08 e:\src\inbound\obj-i686-pc-mingw32\build\win32\tmphzfo2c.list:
 4:43.08     crashinject.obj
 4:43.08 
 4:43.08 LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt
 4:43.08 
 4:43.08 e:\src\inbound\config\rules.mk:742:0: command 'e:/src/inbound/obj-i686-pc-mingw32/_virtualenv/Scripts/python.exe e:/src/inbound/config/expandlibs_exec.py --depend .deps/crashinject.exe.pp --target crashinject.exe --uselist -- link -NOLOGO -OUT:crashinject.exe -PDB:crashinject.pdb  -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -SAFESEH  -DEBUG -DEBUGTYPE:CV -DEBUG -OPT:REF    crashinject.obj ./module.res kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib  kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib' failed, return code 1123
 4:43.08 <libs>: Found error
 4:43.08 <../../dist/bin/crashinject.exe>: Found error
This happens because Microsoft .NET 4.5 is incompatible with Visual C++ 10. The workaround is to ensure that you run the .NET version of cvtres.exe rather than the Visual C++ version. I did this by renaming the Visual C++ versions of those files and copying the .NET versions in their place.

C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\cvtres.exe
C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\cvtres.exe

C:\windows\Microsoft.NET\Framework\v4.0.30319\cvtres.exe
C:\windows\Microsoft.NET\Framework64\v4.0.30319\cvtres.exe
That solved the problem.  Neil, thank you so much!
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: